Using the instructions in this thread I disabled the lock screen: Disabling Lock Screen 18.04

...and the phone style slide-up lock screen is still enabled. It is not "locked". However, if I happen to be playing a game, that slide screen function completely locks up my computer. I can't get it back without a hard reboot. I would like a way to completely get rid of the phone style slide up requirement to return to my desktop. Just go from a blank screen (or screen saver) to the desktop when I move my mouse or press a key or anything to wake up the computer.

  • you never want to lock the screen? gsettings set org.gnome.desktop.lockdown disable-lock-screen true try this command, when you want to enable make the value to false. – PRATAP Nov 8 at 8:40
  • I wrote a couple of scripts with that command both to enable and disable the screen lock. Actual locking is not the problem. It doesn't lock, but that slide up screen is still there and locks up my computer if another "input intensive" program, like a game, is running when the slide up screen overruns my computer. – Michael Sardior Nov 8 at 17:35
  • OK.. Slide up is the problem..Understood..you mentioned unity in tags..is this happening even when you use unity as DE? – PRATAP Nov 8 at 17:45
  • 1
    Have you checked with dconf-editor tool also? – PRATAP Nov 8 at 18:06
  • 1
    You should install it. sudo apt update && sudo apt install dconf-editor please note that there is no direct input for slider but many options which may avoid this slider. – PRATAP Nov 8 at 18:22

Ok, here's what I found as a solution, maybe not the best but it works.

sudo dconf_editor

I found these settings:

/org/ukui/power-manager/lock-use-screensaver set to [false]

Result: slideup lockscreen is gone.

/org/ukui/power-manager/lock-blank-screen set to [false]

Result: locking still enabled on blank screen

used the script:

# script to disable lock-screen
sudo gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

Now lock screen is disabled. No slideup screensaver, I also have the script to re-enable the lock screen:

# script to enable lock-screen
sudo gsettings set org.gnome.desktop.lockdown disable-lock-screen 'false'

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.