5

My Ubuntu OS' version is 18.04.1 LTS.

When I start gedit, this is the result gedit screenshot:

enter image description here

Same problem arises with GNOME Calculator:

enter image description here

I think some things wrong with GNOME programs. I wish to know followings:

  • Why is this happening?
  • How can i fix this?
3
  • 1
    *GNOME. Those aren't GNU programs.
    – muru
    Commented Nov 7, 2018 at 19:09
  • 1
    What kind of graphics card do you have? Commented Nov 7, 2018 at 21:15
  • 1
    My laptop have two graphic card. Hd graphics and nvidia. I am using bumblebee. Commented Nov 8, 2018 at 18:15

4 Answers 4

5

You could experience a problem related to input method modules. (https://bugs.launchpad.net/ubuntu/+source/gtk+3.0/+bug/1760818)

Try starting e.g. gedit by disabling GTK_IM_MODULE

GTK_IM_MODULE=none gedit

and check whether the issue is gone.

If it is gone, you could try to set GTK_IM_MODULE to none by invoking

im-config

and selecting choice "none" in the dialogs.

A reboot is necessary, afterwards.

2
  • This fixed my problem. When I set it back to IBus and rebooted, the problem was still fixed. This answer should be marked as the correct answer. Commented Feb 25, 2019 at 14:34
  • I have the same issue when using gnome-calculator and gedit. This answer fixes the issue for me.
    – htaccess
    Commented Feb 10, 2020 at 0:14
1

By the way - your calculator may be a 'snap' program.

Try: sudo snap install gnome-calculator

Try: sudo snap refresh

1
  • I have tried already but not working. And also problem is not special to calculator. The exact same thing happens to also gedit. Commented Nov 7, 2018 at 20:06
1

Install the 'Synaptic Package Manager' and search for gedit,

using:

sudo apt-get update 
sudo apt-get install synaptic

This will help to figure out what is going on with any program/package issues.

6
  • I don't understand how can I use synaptic package manager to solve the problem. Commented Nov 7, 2018 at 20:09
  • 1
    Did you install it and try to search gedit ? .............It's self explanatory, if there is a problem synaptic will indicate if there is a problem with the install, ie: broken package, unmet dependencies, wrong version etc ..... Commented Nov 7, 2018 at 20:16
  • I am using synaptic already. But it doesn't indicate anything. Everything seems normal. Commented Nov 7, 2018 at 20:38
  • 1
    Hmmm. I don't know what the problem could be. The only suggestion I have is to open synaptic, search gedit, right click and choose 'mark for complete removal', click apply and after it completes, right click and 'mark for installation' then after the reinstall click on the 'reload' icon, then click the 'mark all upgrades' ...follow through if there are any upgrades. Click on the 'apply' icon and that's it. If that doesn't fix it, then it's above my pay-grade. Commented Nov 7, 2018 at 21:03
  • Also take a look at these links: snapcraft.io/gedit .......snapcraft.io/gnome-calculator Commented Nov 7, 2018 at 21:09
0

This link may be of help:

gedit not working? [duplicate]

Using: apt-get install --reinstall gedit must have space before the --reinstall

or:

sudo apt-get purge gedit && sudo apt-get install gedit

Also try:

sudo apt-get purge gedit gedit-common
sudo apt-get clean
sudo apt-get install gedit

And do it for the Gnome calculator:

sudo snap remove gnome-calculator

and enter the following to install the deb version:

sudo apt install gnome-calculator

Another possibly is to update the 18.04.1 OS system with:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -f
17
  • 1
    I have had tried but it is not working. And also problem is not special to gedit. Commented Nov 7, 2018 at 18:33
  • Can you open gedit from the ubuntu search icon for "gedit", i.e. without using terminal? Commented Nov 7, 2018 at 18:37
  • It is not also working. Commented Nov 7, 2018 at 19:11
  • I have tried your last edit but not working. Commented Nov 7, 2018 at 19:20
  • 1
    Sorry, I am not a native English speaker and I think I have used wrong words. I have no problem with terminal. By "working", I meant any of the solutions you recommended didn't solve the issue. Commented Nov 7, 2018 at 20:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .