I've recently installed Lubuntu on an older laptop, and everything was fine until the font got huge on some desktop apps, like "MySQL Workbench", for example.

You can see it on the attached screenshot. Some of the font sizes are normal but others are huge and make using the app really hard.

Lubuntu huge unreadable font

I've tried the obvious "Preferences/Customize Look And Feel" and also "Preferences/Openbox Configuration Manager" but to no avail.

Is there anything else I can try short of reinstalling the OS? Surely these font sizes must be defined somewhere, right?

  • 1
    Telling us the version of Lubuntu would be helpful, as some use LXDE (using GTK+) as their DEsktop, the more recent uses LXQt. The program in question (in my opinion) is using a different configuration to your DEsktop (ie. one is using Qt libs, the other GTK+, so I'd recommend using a GTK+ theme that matches well with your chosen Qt theme (to avoid these issues). This is a theory (it does cause this issue) , but your actual cause may differ - and the start requires knowledge of whether or not you are using GTK+ based LXDE or LXQt (ie. version of Lubuntu used) – guiverc Nov 7 at 11:46
  • ps: I did a quick search online, the version of MySQL Workbench that showed up was based on GTK+ (which may not match the version you are using), so are you using LXQt? (Lubuntu 18.10? or earlier with LXQt selected?). If using 18.04 or earlier, you maybe able to login using LXDE & change theme there, and have it improve your issue. – guiverc Nov 7 at 11:48
  • Here you go: Lubuntu's version is "Ubuntu 18.04.1 LTS" and MySQL Worbench version is "6.3.8 build 1228 CE 64 bits". Thanks for helping! – Pedro Araujo Jorge Nov 7 at 12:16
  • I don't know MySQL Workbench, and didn't see it in repo's, so I can't query it's actual build from my system as to it's build, details & config. My guess was you were using 18.10 (or earlier & using LXQt) but you didn't mention LXQt or LXDE so I'm guessing LXDE (so GTK+ based), meaning your possible clash is GTK+2 (LXDE's base) & GTK+3 (a more modern gnome designed app). I would suggest firstly opening Openbox Configuration Manager - Appearance settings & check fonts (& sizes). I would next try different themes (same Openbox Config Mgr) to see if you can find one that works better for you – guiverc Nov 8 at 2:51
  • My own default (Taqua from 2007; themes are in /usr/share/themes) has only config for GTK+2 so it provides no control for later GTK+3 apps - which may be your issue, but I looked for a gtk+3 program that created a clash like you describe & couldn't find one. – guiverc Nov 8 at 2:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.