16

I needed to locally edit remote files on my server, so I tried to mount the whole remote file system (/) on my local system with SSHFS like so:

 $ sshfs username@domain.com:// /mnt -p 22

Then it stuck (cursor blinking, no output), so obviously I cancelled it with Ctrl+C.

After that, the mount point folder /mnt became sort of unusable, unreachable (you name it) and kept returning me this error message on any attempt to access it:

fuse: bad mount point `/mnt': Transport endpoint is not connected

And it took this weird look in its parent folder:

$ ls -l /
...
d?????????   ? ?    ?        ?            ? mnt`
...

How can I resolve the error and get back to normal?

What should I do to be able to use SSHFS?

1 Answer 1

22

1. Kill all sshfs processes

  • Either with killall command:

    killall sshfs
    

    or selectively:

  • Find all running sshfs processes:

    ps -ef | grep sshfs | grep -v grep
    

    Say you've got two of them running:

    $ ps -ef | grep sshfs | grep -v grep
    root     10906  5170  0 07:14 pts/0    00:00:00 sudo sshfs
    root     10907 10906  0 07:14 pts/0    00:00:00 sshfs 
    
  • Now kill them both or selectively by identifying them by their PID:

    sudo kill -9 10906 10907
    


2. Unmount your mount point

sudo umount -l /mnt


3. Edit /etc/fuse.conf so you never meet the fuse: bad mount point `/mnt': Transport endpoint is not connected error again:

  • Open it as root with your favorite editor, for example

    sudo atom /etc/fuse.conf
    
  • Uncomment the user_allow_other line.
  • Save and close.


4. Use SSHFS with the following options:

sudo sshfs \
-d \
-o allow_other \
-o reconnect \
-o ServerAliveInterval=15 \
user@domain.com:/ /mnt \
-p 12345 \
-C
  • -d turns debug mode on (gives more output)
  • -o stands for "option"
  • -p allows you to specify port number
  • -C turns on compression

Sources:

6
  • 5
    Didn't work for me, still hangs.
    – barnhillec
    Jan 14, 2019 at 22:19
  • Didn't work for me, but I realized that I can go through the folders of the mount via terminal. This indicated that Nautilus has messed up!. To confirm this, I installed Krusader and navigated to that folder without any error or issue. At this point I suggest you quickly check with terminal and another file manager instead of mounting and unmounting multiple times and etc. Dec 19, 2019 at 8:48
  • In my case I figured out it wasn't really hanging, I was just trying to reach something unreachable, and probably didn't wait long enough. Cursor might also have not been blinking. Got me the same error message after ctrl-c.
    – dasWesen
    Jan 23, 2020 at 10:25
  • 1
    Key here is to use sudo with umount. Without it messages like "Device or resource busy" or "Transport endpoint is not connected" pop up. Oct 8, 2020 at 9:16
  • I was using Android File Transfer (aft-mtp-mount) and sudo umount -l /mnt worked for me Oct 29, 2021 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.