69

I have Google Chrome Version 70.0.3538.77 (Official Build) (64-bit).

Today, after running sudo apt update and sudo apt full-upgrade, I saw:

E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.

I looked at the man page for apt-secure but it's pretty technical and difficult, at least for me, to follow.

So how do I fix this issue?


Edit: for now, I've removed the existing Google Chrome ppa from Software Sources and then ran sudo apt update and sudo apt full-upgrade successfully with the following being installed/upgraded successfully:

The following NEW packages will be installed:
  python3-netifaces
The following packages will be upgraded:
  netplan.io nplan ppp
3 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
85

This issue has existed for some time:

The error message clearly shows that this has to do with Google changing its name from Google, Inc to Google LLC. The error message shows what's wrong, but does not tell us what command to run to fix this problem.

How can I accept this change explicitly as the message says?

As stated in the question linked to above from June 2018, the issue related to chrome-remote-desktop and the solution is simply to run sudo apt update and to respond with y at the prompt.

This is what I see when I run just sudo apt update without chaining it with sudo apt upgrade:

E: Repository 'http://dl.google.com/linux/chrome/deb stable Release' changed its 'Origin' value from 'Google, Inc.' to 'Google LLC'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Do you want to accept these changes and continue updating from this repository? [y/N] y
Get:8 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,130 B]                                                    

Running just sudo apt update provides the [y/N] prompt.

  • 27
    changing from sudo apt-get update to sudo apt update fixed it for me. – sdexp Nov 13 '18 at 8:33
  • @sdexp It would be helpful if it was also made as an answer since it wouldn't be noticed in the comments. – Wolverine Dec 16 '18 at 8:07
18

For anyone that is using Ansible or similar tools to deal with this prompt on multiple hosts, here is what I found worked for me.

While apt -y update worked in an interactive environment I couldn't get it to work in Ansible's ad hoc env. I tried various combinations of options and force-yes options but none seemed to work.

There is probably a better way but this is the command that seemed to get the change accepted on all the hosts:

apt-get update -y --allow-releaseinfo-change

protected by Community Nov 26 '18 at 12:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.