1

This question already has an answer here:

I have a fresh installation of Ubuntu 18.10. Using the disc management tools in Windows I was able to shrink the volume and give myself 200G for Ubuntu.

I am trying to mount the Windows partition so that I can place my music (abt 240G) and my photos (abt 400G) on the Windows partition and have full access to all the files. So far, even when using the examples below, "Permissions" says I have full access, yet I cannot change anything on that partition. Using the examples in: NTFS data partition can't be accessed by another user unless unmounted in my current user session before logging out

I have edited my /etc/fstab:

    # Example:
    # Windows Partition - targetted for /media/win7
    # UUID=UUIDOFPARTITION  /media/win7    ntfs-3g     defaults,locale=en_US.utf8,windows_names,umask=7000,uid=1000,gid=1000,user  0   0
    #
    # first solution:
    # UUID=82B86F5AB86F4C2B /Windows ntfs-3g defaults,local=en_US.utf8,windows_names,umask=7000,uid=1000,gid=1000,user 0 0
    # The above did not work. 
    #
    # second solution:
    # Example:
    # UUID=0123456789ABCDEF    /mnt    ntfs-3g    rw,exec,async,auto,user,locale=en_US.utf8,windows_names,umask=7007,gid=654    0    0
    # 
    # My next solution:
    # UUID=82B86F5AB86F4C2B /Windows ntfs-3g rw,exec,async,auto,user,locale=en_US.utf8,windows_names,umask=7007,gid=1001, 0 0
    UUID=82B86F5AB86F4C2B /Windows ntfs-3g rw,exec,async,auto,user,locale=en_US.utf8,windows_names,umask=7007,uid=1000,gid=1001, 0 0

This did not result in being able to read and write to the NTFS partition on the single hard drive. I tried with and without the uid=1000. I created the group and added myself to 'ntfs-access' with gid="1001" (quotes removed).

marked as duplicate by user68186, karel, Fabby, Thomas, Charles Green Nov 11 '18 at 15:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    If you're trying to mount your Windows C: disk to be able to do this, I can strongly recommend not to do that. You will probably corrupt it in the long run. I'd recommend creating a new standalone NTFS partition, and sharing that between Windows and Ubuntu. Then use something like UUID=xxxxxxxxx /media/your_username/Shared_Data ntfs-3g defaults 0 0 – heynnema Nov 6 '18 at 20:01
  • Noted. I had that arrangement with a Windows 7 computer and an older version of Ubuntu. I had no problems with it. I now know that fast shutdown will need to be disabled on the Windows 10 and if there are any other caveats I would be open to learning them. I have serious space considerations and the more partitions the less available space. – Michael Sardior Nov 6 '18 at 20:06
  • 1
    Be careful, as some Windows 10 Updates wipe out Ubuntu partitions on MBR disks. – heynnema Nov 6 '18 at 20:54
  • Disabled Fast-boot in Windows 10, access to files now works correctly. – Michael Sardior Nov 6 '18 at 21:11
  • @heynnema, I had that happen when I updated from win7 to win10 a few years ago. Reset the partition flags and I was back up and running again. – Michael Sardior Nov 6 '18 at 21:18
1

There is a ”fast startup“ option in windows leaving the partition in an inconsistent state. Linux cannot write to those partitions—try do disable this option in windows.

There is a thread already dealing with this problem and explaining it in more detail.

  • This thread answers the question why I couldn't mount the partition in rw mode. After changing the Windows boot to normal instead of fast-boot the original instructions work. Apparently Ubuntu 18.10 looks at the fast-boot flags in Windows and finds it set, then mounts the partition in read-only mode, no matter what /etc/fstab has in it. – Michael Sardior Nov 7 '18 at 0:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.