0

I am trying to set up file associations in FileZilla 3.38.1 on Ubuntu 18.04.1 LTS.

If I double-click on eg. test.php in Files it will open in gedit.

So in FileZilla > edit > settings > Filetype Associations I tick the "Inherit system's filetype associations" (there is nothing else defined in there) and right click > Open a LOCAL test.php it asks me if I want to open it with "Text Editor", "LibreOffice Writer" or "Atom" and opening with those works. I would expect it to just open with the default editor, gedit.

If I right-click > View/Edit on a remote test.php I get an error- "An assertion failed. ./src/common/filefn.cpp(1610): assert "!szFile.empty()" failed in wxFindFileInPath(): empty file name in wxFindFileInPath" and whichever button I choose, "Stop" or "Continue" FileZilla crashes. I would expect FileZilla to download a temp local copy of the file and open it in gedit.

Also if I right-click > Edit on a LOCAL test.php I get the same error/crash.

So, I try to set up gedit as the default editor in FileZilla Filetype Associations.

First, I type into the Terminal which gedit and the response is: /usr/bin/gedit

If I type /usr/bin/gedit in the terminal gedit starts.

So in filezilla I try - php "/usr/bin/gedit" (also tried without quotes)

FileZilla tells me "Associated Program not found".

In local file window in FileZilla, if I go to /usr/bin I cannot see a gedit file or folder, yet I can see it in Files or via "ls" in terminal.

Why can't Filezilla see gedit?

  • 1
    Have you tried associating file types with applications using your file manager instead of the application? Browse to a PHP file, right-click and look for the "open with" tab, then select a text editor. Does this help, or am I misunderstanding your question? – Tom Brossman Nov 6 '18 at 16:44
  • Opening files in "File Manager" works fine. I want to open remote files in FileZilla so I can view or edit them. Usually, it would download a local copy and then edit it in the default editor, and give me the option to upload it again if I changed it, but it doesn't. – Chris L Nov 6 '18 at 17:28
1

you've this probleme because you have install a snap Filezila(UNOFFICIAL) from ubuntu app store. This work for me. purge the current filezilla and do reinstall like this in terminal command

sudo apt-get install filezilla

  • I had the same problem with the Flatpak version and installing from apt really fixes the problem. – Omer Sabic Sep 12 at 7:28
0

You was almost right in your setup, you just had to add the extension.

in your example you had /usr/bin/gedit

All you needed was php /usr/bin/gedit

Hopefully this will work for you.

  • That's what I tried. It seems that FileZilla cannot see gedit. I've been using FileZilla on Ubuntu and Linux for years, never had problems like this before. – Chris L Nov 7 '18 at 20:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.