1

When I suspend my Laptop it suspends fine (takes a bit until the fans turn off), but when I wake it there's only a static underscore at the top left and i have to hold the power button to restart the laptop. I am running the 4.15.0-1024-oem kernel on Ubuntu 18.10 with the proprietary nVidia drivers 390 installed via the Software & Updates GUI, on an nVidia Quadro P2000. I have tried the 410 drivers with the 4.19.1 kernel but that yields the same result. The only time it worked properly was on kernel 4.19.1 before I installed the 410 drivers, and the 390 were incompatible with the kernel and therefore not loaded.

glxinfo | grep OpenGL 

yields the following

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro P2000/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.87
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.87
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.87
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
0

I have the same device since yesterday but with the P1000 and Ubuntu 18.04.

I've run into the same problem.

The only working solution for me was using the free Nouveau driver.

  • 1
    Yeah, I just decided to live with the problem, since without the nvidia driver the laptop just uses the intel graphics in firefox and maxes out individual cores, and firefox also uses the intel graphics for hardware acceleration without the nvidia drivers. – aloevera Nov 11 '18 at 2:39
  • I don't really experience any major problems with the Intel GPU. It would be nice to have the P1000 for gaming but at least it doesn't use tons of power. – Nebucatnetzer Nov 12 '18 at 21:59
  • I don't have the exact same specs as your model. However I've got mine finally working with the following setup. - Ubuntu 18.04 - No changes to grub - Installed all the linux-generic-hwe packages - installed the nvidia-390 driver After this everything (suspend ect.) seems to be working in Gnome Wayland and ARMA 3 gives me decent frame rates. I've only tried it today and therefore haven't really invested much time into Gnome Xorg or i3wm. However it seems to crash everytime I select one of those environments. – Nebucatnetzer Jan 4 at 10:22
  • Isn't nvidia disabled in Wayland and the default driver is used? – aloevera Jan 9 at 16:13
  • Is that still the case? I must admint I'm really bad with this GPU stuff. I never really got a dual graphics setup to work reliably on any of my notebooks. Do you know how to check which card it's using? – Nebucatnetzer Jan 10 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.