1

I'm running ubuntu cosmic and have tried searching for a solution, but all solutions are regarding pip: command not found

pip seems to work fine (freshly installed via sudo apt-get install python-pip). After this I ran pip install modulename which also worked fine, but once I try running the module, I receive a command not found.

I did check echo $PATH which does not contain the directory the modules are installed to (~/.local/lib/python2.7/site-packages), but I have not found a single post that seemed to have the same problem as mine, and I already learned that wildly running commands in the hope to find a solution is more likely to break things.

In case it helps, I'm trying to run keen and keenmqtt.

I hope somebody is able to help :) Thanks!

  • 1
    ahh there's a mistake in my post, i Installed python-pip, not pip. Sorry! – 0xDE4DBEEF Nov 6 '18 at 13:01
2

solved it by adding export PATH=$PATH:$HOME/.local/bin to ~/.bashrc

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.