1

Since I've upgraded tot Ubuntu 18.04 (and afterwards to 18.10) I'm having problems with Bluetooth connection. For instance, the music with my Bluetooth speaker lags seriously. Upon investigating dmesgI'm encountering lots of these errors:

Bluetooth: hci0: last event is not cmd complete (0x0f)

I tried to update bluez(5.48 -> 5.50) through the official PPA, but this did not work out.

Output from lsusb | grep Blue

Bus 006 Device 003: ID 0930:0508 Toshiba Corp. Integrated Bluetooth HCI

Strangely, I have 2 Bluetooth devices list when executing rfkill list

0: Toshiba Bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Output from dmesg | egrep -i 'blue|firm' might indicate some problems with the firmware:

[    0.069143] acpi PNP0A08:00: [Firmware Info]: MMCONFIG for domain 0000 [bus 00-3f] only partially covers this bridge
[   18.813225] toshiba_bluetooth: Toshiba ACPI Bluetooth device driver
[   19.651213] iwl4965 0000:01:00.0: loaded firmware version 228.61.2.24
[   55.834864] iwl4965 0000:01:00.0: Enabling power save might cause firmware crashes
[ 1204.278716] Bluetooth: Core ver 2.22
[ 1204.278758] Bluetooth: HCI device and connection manager initialized
[ 1204.278764] Bluetooth: HCI socket layer initialized
[ 1204.278771] Bluetooth: L2CAP socket layer initialized
[ 1204.278783] Bluetooth: SCO socket layer initialized
[ 1204.664153] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 1204.664155] Bluetooth: BNEP filters: protocol multicast
[ 1204.664162] Bluetooth: BNEP socket layer initialized
[ 1204.769152] Bluetooth: RFCOMM TTY layer initialized
[ 1204.769161] Bluetooth: RFCOMM socket layer initialized
[ 1204.769172] Bluetooth: RFCOMM ver 1.11

My kernel version:

4.18.0-10-generic

How could I solve this please?

0

This problem has disappeared without any action from my side, probably an update or so.

I Will marked this as solved.

Wouter

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.