0

The problem is with 18.10 cosmic desktop after a do-release-upgrade. Before the release upgrade I did not have this issue, or at least I did not notice it.

The issue is that when the OS starts, the graphical interface just won't start no matter how long I wait. I only see an empty black screen with a blinking cursor at the top left corner of the screen. GUI definitely worked before the release upgrade, althoug I had occassions where I needed to manually switch to the graphical terminal. This happened rarely, only a handful of times, so I didn't bother to hunt the problem down.

I found a strange workaround: pressing CTRL+ALT+F2 and then CTRL+ALT+F1 switches terminals, and shortly the GUI starts up properly.

Then I accidentally noticed that there are not one, but two GUIs are running, one on VT #1 (accessible with CTRL+ALT+1), and an other one on VT #3 (CTRL+ALT+3).

If I run the command ps fauxww I can clearly see two xorg instances running on vt1 and vt3, forked by gdm-x-session worker processes, those were started by their respective gdm-session-worker processes, both of which are started by a single gdm3 process.

Is this normal? (Not likely...) I think there should only be a single GUI process. Could the multiple running GUI instances have anything to do with not being able to start up properly?

Thank you.

2

We need to know if the bug is in the X11 configuration or the display manager (the login screen). Currently, in my system, I note that if I have any xorg.conf file--anything whatsoever--the nvidia driver will not start X itself. Moving xorg.conf allows nvidia-390 or nvidia-410 to start. Same problem does not seem to affect X when I turn off the nvidia drivers.

Putting X aside, consider the display manager. For me (and many others, if you check), there is a bug in gdm3, it won't start for either. I'm still digging into all of the reasons, but best suggestion now is to install the lightdm display manager. It will start. You can make sure which is selected if you run

dpkg-reconfigure lightdm

If the login display manager still fails to start, I suggest you turn off the graphical login and let the system boot up and come to a CLI login prompt. Here's how to turn off the graphical login:

systemctl set-default multi-user.target

I learned that at https://wiki.debian.org/GDM#Removing_autologin_in_gdm3_and_getting_more_verbose_output_in_GDM

From there, you have more freedom to test both the raw X session with

startx

The important there is to see if X itself starts.

And you can also you can test with display managers. Launch with these with systemctl. For example, right now

sudo systemctl start lightdm

or if you want to see the black screen again, put gdm3 instead of lightdm.

When you ask more questions, please remember to tell us output from

uname -a

and the video part of the output from

lshw
0

After trying for a few days to hunt this down, I ended up reinstalling the whole system.

The default driver for NVidia cards is nouveau, and it works fine. Well, it causes some weird flickering on the login screen, and 3D games are very slow, but at least it boots OK.

Than - for some reason - I ended up looking at /etc/gdm3/custom.conf, and changed the line:

#WaylandEnable=false

to:

WaylandEnable=false

e.g. disabling gdm3 to use wayland. This also worked well with nouveau. I felt like it's my lucky day and tried to use the official NVidia driver (390) AND IT WORKED.

With wayland disabled in the gdm3 custom.conf and the 390 NVidia driver, my machine boots up correctly. It still boots slower than nouveau, but it does indeed, and Kerbal Space Program runs faster than 4 frames per second. Brilliant! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.