2

The virtual PDF printer is no longer available. It was based on cups-pdf. Since 18.04 it is gone. No error message. Just disappeared in GUI for printer control. Worked fine before the upgrade.

New install of cups-pdf is possible but does not help. It tells:

    [...]
        Note, selecting 'printer-driver-cups-pdf' instead of 'cups-pdf'
        printer-driver-cups-pdf is already the newest version (3.0.1-5). 
[...]

But not a trace of PDF printer functionality in the gui printer setup. Applications do no longer show the cups-pdf "printer".

Question: How can I get the (cups-) pdf back in 18.04? Is there a workaround?

1
2

The problem is not occuring if the distro-update to Ubuntu 18.n did never have an installation of cups-pdf before. So it is clearly update related.

This process provides a workaround (does not always help):

  1. Purge cups-pdf

    sudo apt -y purge cups-pdf
    
  2. Purge the substitute-stuff (since 16.n)

    sudo apt -y purge printer-driver-cups-pdf
    
  3. Clean up.

    sudo  apt-get install  check
    sudo apt -y autoremove
    
  4. Reboot. (smart guys will find a way to just restart the services ;-) )

    sudo reboot
    
  5. Reinstall cups-pdf.

    sudo apt -y install -V cups-pdf
    

    Monitor closely if it provides positive comments.

    Out of curiosity: Please watch out if there is a PPD update process mentioned in the last installation step (up to now only traced in totally new installs).

  6. Check.

    The result in the GUI menu: In "Printers" PDF should be back.

    If PDF doesn't come back in the Printers menu leave a comment here and submit a bug report mentioning bug 1801805 (link in comment above). This workaround is not the solution for the root cause! It may be important for the developer to get more details from different machines.

3
  • meanwhile I read the responsible entity for this problem is "app armor". There is a long and interesting discussion of several(!) ways to fix the app armor failures here: bugs.launchpad.net/ubuntu/+source/cupsys/+bug/147551 A few key words here (all references in the bug mentioned above!): sudo vim /etc/cups/cups-pdf.conf sudo vim /etc/apparmor.d/usr.sbin.cupsd (this is the nuisance) other issues: /etc/apparmor.d/tunables/home sudo dpkg-reconfigure apparmor sudo aa-complain cupsd (kind of disables strict apparmor for cups) Jul 10 '19 at 21:24
  • This worked for me without having to reboot at step 4.
    – JayDin
    Nov 26 '19 at 5:58
  • I did sudo systemctl restart cups-browsed cups for step 4
    – gerardw
    Feb 20 '20 at 15:31
0

I had been avoiding cups-pdf believing that I was responsible for it not behaving on my machine.

When I realised the same thing was happening under Mint 19.1 as well as Ubuntu 18.04 (and found the time), I found your work-around above.

However, when I redirected the 'Out' statement in cups-pdf.conf to:

Out /home//Documents/pdf_files

instead of:

Out {HOME}/PDF

it failed.

When I changed it back, it worked again.

2
  • 1
    Clearly noted in the cups-pdf.conf that AppArmor settings has to be updated. More info at: bugs.launchpad.net/ubuntu/+source/cupsys/+bug/147551
    – reddot
    Apr 18 '19 at 12:21
  • You need to edit the apparmour setting file sudo gedit /etc/apparmor.d/usr.sbin.cupsd #at the bottom after the default home PDF add your path @{HOME}/Documents/pdf_files/ rw, @{HOME}/Documents/pdf_files/* rw, restart apparmour sudo systemctl restart apparmor.service
    – pt123
    Apr 22 '20 at 1:50
0

As of Ubuntu 18.04, the package name is printer-driver-cups-pdf, and the default directory of printing is /home/user/PDF/.

At your situation I would try to purge and reinstall it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.