0

I have a computer (name=Amazon1, UBUNTU 18.04) that can’t “see” any other computers on my local LAN.

I have searched the Internet and it seems like 95% of the information is about connecting TO a computer (setting up a “share”). This is working. I can also connect to the Internet so the network interface seems to be working.

I can ping other network computers on my LAN. But, the other network computers don’t show up in the File Manager – Other locations section. If I put gio mount smb://Gateway/c/ in the Terminal, I get the error message

gio: smb://gateway/c/: Location is not mountable

“gateway” is another computer on the network. It doesn’t matter if the name I use is a Windows 10, Windows XP, or UBUNTU 18.04 computer.

If I use a IP address in the above command also doesn’t work even though I can ping the IP address.

To the best of my knowledge, I have this set up the same as other network computers (smb.conf, nsswitch.conf files) which all can "see" computers on the LAN.

THIS WAS WORKING UNTIL ABOUT 3 WEEKS AGO. Maybe something got corrupted during a power outage.

I have completely uninstalled Samba and re-installed it (using Synaptic).

I can’t seem to find any messages in the Samba log that sheds any light on my issue.

Any ideas of where to look or packages that should be re-installed?

  • 1
    have you tried running a diagnostic on your network to see what ports are available on your machines? something like (assuming your local net is 192.168.0.X) nmap -F 192.168.0.0/20 this will scan your net for all machines and list available ports... this can help us see if samba is still running – Joshua Besneatte Nov 5 '18 at 15:27
  • $ nmap -F 172.16.0.0/20 Starting Nmap 7.60 ( nmap.org ) at 2018-11-05 11:36 EST Stats: 0:00:24 elapsed; 0 hosts completed (0 up), 4096 undergoing Ping Scan Ping Scan Timing: About 93.40% done; ETC: 11:36 (0:00:02 remaining) Nmap scan report for homeportal (172.16.0.1) Host is up (0.028s latency). Not shown: 98 closed ports PORT STATE SERVICE 80/tcp open http 443/tcp open https Nmap scan report for Gateway2 (172.16.1.34) Host is up (0.00036s latency). Not shown: 98 closed ports PORT STATE SERVICE 139/tcp open netbios-ssn 445/tcp open microsoft-ds – bob Nov 5 '18 at 16:38
  • I ran the command and the output is shown above. Output is identical on a "good" computer and my "bad" computer. Too bad the formatting is better. There were 9 more entries. I didn't post them all here – bob Nov 5 '18 at 16:40
  • In System Monitor, a "working" machine shows 2 entries for smbd and one entry of nmbd. My "not working" machine show 3 entries for smbd and one for nmbd. – bob Nov 5 '18 at 16:46
  • It almost sounds like you are missing the gvfs backend so install it: sudo apt install gvfs-backends – Morbius1 Nov 5 '18 at 16:46
0

When I've received this error in the past, it wound up being a permissions issue on the server. Check the permissions on the share's root folder and make sure it's accessible both to the samba user and others (or just open it up with sudo chmod 777 sharefolder).

If you've reinstalled samba, also ensure that you reconfigure the samba group user with smbpasswd username.

  • I did the chmod with no improvement. I am not sure how to do the reconfigure smbpasswd thing. – bob Nov 5 '18 at 17:16
  • Substitute "sambauser" for the username you use to log in to your shares: smbpasswd sambauser this should prompt you for a password and then should automatically add the username specified to the smb group. from there, use this username on any machine trying to access the shares on the server you configured. – Minty Nov 5 '18 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.