0

I have a file server running 1TB HDD (sdb) with a single partition and two directories shared via Samba that are accessible by our Windows, Mac and Ubuntu computers. This setup works perfectly.

I installed a new 4TB drive (sdc) and partitioned it to two 2TB drives (FAT limitation), and shared a directory on each. I thought I did everything the same as on the 1TB drive. I can see them on my Ubuntu laptop in "Other Locations", but cannot mount them. Error states: "Unable to access location, failed to mount Windows share: file exists."

Results of lshw command:

sudo lshw -short | awk '/disk|volume/' /0/1/0.0.0 /dev/sda disk 120GB WDC WDS120G1G0A-
/0/1/0.0.0/1 /dev/sda1 volume 111GiB Linux LVM Physical Volume partition
/0/2/0.0.0 /dev/sdb disk 1TB TOSHIBA DT01ACA1
/0/2/0.0.0/1 /dev/sdb1 volume 931GiB EXT3 volume
/0/3/0.0.0 /dev/cdrom disk DVD RW AD-7201S
/0/4/0.0.0 /dev/sdc disk 4TB WDC WD40EZRZ-00G
/0/4/0.0.0/1 /dev/sdc1 volume 1863GiB Windows FAT volume
/0/4/0.0.0/2 /dev/sdc2 volume 1863GiB Windows FAT volume

Results of the lsblk command:

sudo lsblk

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT

sda 8:0 0 111.8G 0 disk
└─sda1 8:1 0 111.8G 0 part
├─ubuntuServer--vg-root 253:0 0 108.1G 0 lvm /
└─ubuntuServer--vg-swap_1 253:1 0 3.7G 0 lvm [SWAP]
sdb 8:16 0 931.5G 0 disk
└─sdb1 8:17 0 931.5G 0 part /mnt/FilesDrive
sdc 8:32 0 3.7T 0 disk
├─sdc1 8:33 0 1.8T 0 part /mnt/FilesDrive1
└─sdc2 8:34 0 1.8T 0 part /mnt/FilesDrive2
sr0 11:0 1 1024M 0 rom

fstab is as follows:

file system, mount point, type, options, dump, pass
/dev/mapper/ubuntuServer--vg-root / ext4 errors=remount-ro 0 1
/dev/mapper/ubuntuServer--vg-swap_1 none swap sw 0 0
/dev/sdb1 /mnt/FilesDrive auto defaults 0 2
/dev/sdc1 /mnt/FilesDrive1 auto defaults 0 2
/dev/sdc2 /mnt/FilesDrive2 auto defaults 0 2

Permissions are not the same between the drives, and are as follows: /mnt/FileDrive root root drwxr-xr-x /mnt/FileDrive/Folder1 dwayne dwayne drwxrwxr-x /mnt/FileDrive/Folder2 dwayne dwayne drwxrwxr-x /mnt/FileDrive1 root root drwxr-xr-x /mnt/FileDrive1/Folder1 root root drwxr-xr-x /mnt/FileDrive2 root root drwxr-xr-x /mnt/FileDrive1/Folder2 root root drwxr-xr-x

When I try to change the owner and group o the partition or folder to 'dwayne dwayne' I get the error "chown: changing ownership of 'mnt/FilesDrive[1 or 2][/any subfolder]': Operation not permitted".

I have searched through this site and others and cannot figure out why I cannot change the ownership of the partitions and folders, i this is the issue.

  • FAT does not support permissions. Why FAT? – user880592 Nov 5 '18 at 1:38
0

A fat32 partition will mount by default with owner=group=root and permissions of 755 (drwxr-xr-x).

To alter permissions you cannot use chown or chmod because Fat32 has no Linux permissions bits to set. You need to make these changes when you mount which is the opposite of what you do with a Linux filesystem.

This:

/dev/sdc1 /mnt/FilesDrive1 auto defaults 0 2

Becomes this if you want to change ownership:

/dev/sdc1 /mnt/FilesDrive1 auto defaults,uid=dwayne,gid=dwayne 0 2

Or you can change permissions so that it is available to everyone:

/dev/sdc1 /mnt/FilesDrive1 auto defaults,umask=000 0 2

Or a combination of both.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.