7

I run Ubuntu 16.04 dual booted with macOS Mojave on a 2013 macbook pro. Up until a week or so ago, the play/pause/skip keys worked perfectly with Spotify. Now they aren't responsive at all. I recently updated to Mojave on my mac side but I don't know if that's the issue. Restarting does not help. Any suggestions welcome!

17

Ok, found the answer. Not sure why is stopped working, but here's how to get it working again. Go into keyboard shortcuts and re-create custom shortcuts:

Play/Pause toggle:

dbus-send --print-reply --dest=org.mpris.MediaPlayer2.spotify /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.PlayPause

Previous:

dbus-send --print-reply --dest=org.mpris.MediaPlayer2.spotify /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Previous

Next:

dbus-send --print-reply --dest=org.mpris.MediaPlayer2.spotify /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Next
  • Worked really well, however I got my original keyboard shortcuts to work by first testing one of the above commands in a terminal. It somehow woke up my system and made the keys work. Did not reboot yet, so will have to see if it is persistant. I am running Mate on ubuntu 18.10 – Denny Dec 12 '18 at 15:25
  • Please refer to this askubuntu.com/questions/1105363/… – Lynob Dec 29 '18 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.