5

When I configure gdm as my default display manager (dpkg-reconfigure gdm3) and then reboot, I get a black screen with a blinking cursor. From there, I cannot do anything since the ttys does not work (ctrl+alt+F1 to F7). I could not figure out why.

In order to resolve this issue, I boot into safe mode, reconfigure lightdm and then reboot.

I observed that gdm could not start for some reason (hence the black screen).

$ systemctl status gdm.service 
● gdm.service - GNOME Display Manager
   Loaded: loaded (/lib/systemd/system/gdm.service; static; vendor preset: enabled)
   Active: inactive (dead)

Nov 04 16:46:05 rigel systemd[1]: gdm.service: Unit cannot be reloaded because it is inactive.

When I manually start gdm systemctl status gdm.service I am able to logout and log back in using gdm. After reboot, the black screen occurs again with the blinking cursor.

Any ideas? Thanks.

GNOME Shell 3.30.1
Ubuntu 18.10 cosmic
Kernel: x86_64 Linux 4.18.0-10-generic
NVIDIA driver 410.73 (GeForce GTX 970)
5
  • How old is this computer? Laptop or desktop? Video card? Does it boot if you set nomodeset in the kernel boot line in GRUB?
    – heynnema
    Nov 4, 2018 at 23:45
  • @heynnema Thanks for the suggestion. The computer is a desktop (not old, about 3 years). My video card is Nvidia GeForce GTX 970. I tried the nomodeset flag in GRUB but I got the same error.
    – m0ur
    Nov 5, 2018 at 12:29
  • 1
    You could try reinstalling gdm3. Maybe the update didn't complete. sudo apt-get update and sudo apt-get install --reinstall gdm3. Then sudo dpkg-reconfigure gdm3 and reboot.
    – heynnema
    Nov 5, 2018 at 13:05
  • I have also tried that, did not work.
    – m0ur
    Nov 5, 2018 at 14:12
  • Update: Disabling Wayland and reinstalling ubuntu-session fixed the issue, as @adrinux suggested.
    – m0ur
    Nov 28, 2018 at 11:31

1 Answer 1

4

I had the same problem on both my Ubuntu 18.04 boxes after upgrade to 18.10. Both are configured with nvidia grahpics and to use the vanilla gnome session Ubuntu provides (not the Unity-ish version they munged together). Much faffing with nvidia drivers had no effect.

I did two other things - not sure which brought it back. From this answer Edit /etc/gdm3/custom.conf as a sudo and uncomment the line to force Xorg over Wayland

WaylandEnable=false

I also installed ubuntu-session:

sudo apt install ubuntu-session

But not sure whether that is really required so I suggest you try editing /etc/gdm3/custom.conf and rebooting first.

hth

5
  • Thanks!! I have tried to disable Wayland WaylandEnable=false (I saw it in the same answer as you), but it had not worked. However, reinstalling ubuntu-session fixed the problem.
    – m0ur
    Nov 28, 2018 at 11:21
  • Out if interest did you revert that change to WaylandEnable=false before reinstalling ubuntu-session?
    – adrinux
    Nov 29, 2018 at 12:48
  • Yes, I first disabled Wayland and then reinstalled ubuntu-session.
    – m0ur
    Nov 29, 2018 at 12:51
  • For me reinstalling ubuntu-session worked. No need to disable wayland. The problem started after upgrade from 18.10 to 19.04.
    – knoftrix
    Aug 8, 2019 at 16:40
  • Installing ubuntu-session worked for me too! Thanks for the help!
    – manarinian
    Oct 24, 2022 at 20:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .