1

I am trying to set up my Ubuntu 16.04 machine to communicate with a lidar scanner (Hokuyo) through my ethernet port (eth0) and have my wifi connect to the internet over wlan0. The lidar communication works fine, but I get no internet through wireless. However network manager says I am connected.

My /etc/network/interfaces file is as follows (i deleted all the wlan0 info while troubleshooting so as of now just have the eth0):

auto lo
iface lo inet loopback

#Hokuyo Sensor
auto eth0
iface eth0 inet static
  address 192.168.0.11
  netmask 255.255.255.0
  gateway 192.168.0.1
metric 800

The wifi is connected through the regular network manager, however I get not internet and cannot ping any websites. Attaching a screenshot of an ifconfig command:

Ifconfig command

And the output from sudo lshw -class network in case that helps troubleshoot:

sudo lshw -class network Thanks!

  • Does it work if you change router IP to 192.168.1.1 – Jeremy31 Nov 4 '18 at 15:18
  • @Jeremy31 Yes, that seems to do the trick. Could you elaborate on why that works? And perhaps a solution that could work if I didnt have access to my router settings (like say if I am at the university campus)? – Tech_Support Nov 4 '18 at 15:31
  • I have heard that you can connect using both wifi and ethernet if they use different subnets, if you are using many different routers that you don't have control of, you may have to change the address of the scanner to make it easier – Jeremy31 Nov 4 '18 at 15:43
  • Changing the subnet of the scanner is a bit of an involved procedure, is there a way for me to change the subnet of my wlan0 through the interfaces file? – Tech_Support Nov 4 '18 at 16:01
  • I don't think that is possible as that is managed through DHCP – Jeremy31 Nov 4 '18 at 16:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.