2

I bought the LOTEKOO USB Wireless Network Adapter, Powerful 5dBi Antenna 600Mbps Dual Band from amazon. I been trying to get it to work with my Ubuntu: "Linux 4.15.0-34-generic #37~16.04.1-Ubuntu SMP Tue Aug 28 10:44:06 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux". First I compiled and installed the drivers per instructions on GitHub. But when I insert the USB Dongle is not detected. Looking at syslog:

Nov  3 14:50:23 pluto mtp-probe: bus: 3, device: 20 was not an MTP device
Nov  3 14:51:49 pluto kernel: [ 1795.291025] usb 3-4: USB disconnect, device number 20
Nov  3 14:51:51 pluto kernel: [ 1797.327114] usb 3-4: new high-speed USB device number 21 using xhci_hcd
Nov  3 14:51:52 pluto kernel: [ 1797.475703] usb 3-4: New USB device found, idVendor=0bda, idProduct=c811
Nov  3 14:51:52 pluto kernel: [ 1797.475709] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov  3 14:51:52 pluto kernel: [ 1797.475712] usb 3-4: Product: 802.11ac NIC
Nov  3 14:51:52 pluto kernel: [ 1797.475715] usb 3-4: Manufacturer: Realtek
Nov  3 14:51:52 pluto kernel: [ 1797.475718] usb 3-4: SerialNumber: 123456
Nov  3 14:51:52 pluto mtp-probe: checking bus 3, device 21: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4"
Nov  3 14:51:52 pluto mtp-probe: bus: 3, device: 21 was not an MTP device
Nov  3 14:51:52 pluto kernel: [ 1797.726714] usb 3-4: USB disconnect, device number 21
Nov  3 14:51:52 pluto kernel: [ 1798.035116] usb 3-4: new high-speed USB device number 22 using xhci_hcd
Nov  3 14:51:52 pluto kernel: [ 1798.183466] usb 3-4: New USB device found, idVendor=0bda, idProduct=c811
Nov  3 14:51:52 pluto kernel: [ 1798.183472] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov  3 14:51:52 pluto kernel: [ 1798.183475] usb 3-4: Product: 802.11ac NIC
Nov  3 14:51:52 pluto kernel: [ 1798.183479] usb 3-4: Manufacturer: Realtek
Nov  3 14:51:52 pluto kernel: [ 1798.183482] usb 3-4: SerialNumber: 123456
Nov  3 14:51:52 pluto mtp-probe: checking bus 3, device 22: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4"
Nov  3 14:51:52 pluto mtp-probe: bus: 3, device: 22 was not an MTP device

Following some instructions I created a udev rules files:

db2admin@pluto:/etc/udev/rules.d$ cat 90-myrules.rules 
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="c811", ATTRS{serial}=="123456"

When I look at the output of:

udevadm monitor --udev --property

UDEV [1662.908962] remove /devices/pci0000:00/0000:00:14.0/usb3/3-4 (usb) ACTION=remove BUSNUM=003 DEVNAME=/dev/bus/usb/003/019 DEVNUM=019 DEVPATH=/devices/pci0000:00/0000:00:14.0/usb3/3-4 DEVTYPE=usb_device ID_BUS=usb ID_MODEL=802.11ac_NIC ID_MODEL_ENC=802.11ac\x20NIC ID_MODEL_ID=c811 ID_REVISION=0200 ID_SERIAL=Realtek_802.11ac_NIC_123456 ID_SERIAL_SHORT=123456 ID_USB_INTERFACES=:ffffff: ID_VENDOR=Realtek ID_VENDOR_ENC=Realtek ID_VENDOR_FROM_DATABASE=Realtek Semiconductor Corp. ID_VENDOR_ID=0bda MAJOR=189 MINOR=274 PRODUCT=bda/c811/200 SEQNUM=7598 SUBSYSTEM=usb TYPE=0/0/0 USEC_INITIALIZED=1648553212

UDEV  [1710.433564] add      /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0 (usb)
.MM_USBIFNUM=00
ACTION=add
DEVPATH=/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0
DEVTYPE=usb_interface
ID_VENDOR_FROM_DATABASE=Realtek Semiconductor Corp.
INTERFACE=255/255/255
MODALIAS=usb:v0BDApC811d0200dc00dsc00dp00icFFiscFFipFFin00
PRODUCT=bda/c811/200
SEQNUM=7619
SUBSYSTEM=usb
TYPE=0/0/0
USEC_INITIALIZED=1709427721

output of sudo lshw -C network:

USB
*-network DISABLED description: Wireless interface product: Wireless 7260 vendor: Intel Corporation physical id: 0 bus info: pci@0000:06:00.0 logical name: wlp6s0 version: 6b serial: e8:b1:fc:50:1f:c7 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-34-generic firmware=17.608620.0 latency=0 link=no multicast=yes wireless=IEEE 802.11 resources: irq:36 memory:f7900000-f7901fff *-network description: Wireless interface physical id: 2 bus info: usb@3:3 logical name: wlx503eaa53e6ba serial: 50:3e:aa:53:e6:ba capabilities: ethernet physical wireless configuration: broadcast=yes driver=r8188eu ip=192.168.1.165 multicast=yes wireless=IEEE 802.11bgn

does not show my third network device just the two that I have and work.

The command:

 lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 005: ID 8087:07dc Intel Corp. 
Bus 003 Device 004: ID 06cb:0ac3 Synaptics, Inc. 
Bus 003 Device 003: ID 0bda:c811 Realtek Semiconductor Corp. 
Bus 003 Device 002: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter
Bus 003 Device 006: ID 0bda:573c Realtek Semiconductor Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

shows my device which is 0bda:c811 Realtek Semiconductor Corp. the second realtek device is another USB Wifi that is working but is not 5G.

sudo lshw -C network
  *-network DISABLED
description: Wireless interface product: Wireless 7260 vendor: Intel Corporation physical id: 0 bus info: pci@0000:06:00.0 logical name: wlp6s0 version: 6b serial: e8:b1:fc:50:1f:c7 width: 64 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless configuration: broadcast=yes driver=iwlwifi driverversion=4.15.0-34-generic firmware=17.608620.0 latency=0 link=no multicast=yes wireless=IEEE 802.11 resources: irq:36 memory:f7900000-f7901fff *-network description: Wireless interface physical id: 2 bus info: usb@3:3 logical name: wlx503eaa53e6ba serial: 50:3e:aa:53:e6:ba capabilities: ethernet physical wireless configuration: broadcast=yes driver=r8188eu ip=192.168.1.165 multicast=yes wireless=IEEE 802.11bgn

I wondering what I am i missing. Thanks for any help provided.

4
  • What results for mokutil --sb-state
    – Jeremy31
    Nov 3, 2018 at 20:37
  • 2
    rtl8812au is not correct for this device: "New USB device found, idVendor=0bda, idProduct=c811" Possibly helpful: github.com/whitebatman2/rtl8821CU Like my colleague @Jeremy31 , I am wondering why you are not able to use the built-in Intel which should easily outperform any USB device, especially one for which there is ony an obscure driver that needs to be compiled from source code.
    – chili555
    Nov 3, 2018 at 20:40
  • @Jeremy31 Not sure what this means but here is the output of mokutil db2admin@pluto:~$ mokutil --sb-state EFI variables are not supported on this system
    – Fabio
    Nov 4, 2018 at 21:12
  • @chili555 Well I feel kind of silly. I am not sure why that answer never pop up on my searches before (wasted so much time) but it worked! Thanks a lot.
    – Fabio
    Nov 4, 2018 at 21:29

2 Answers 2

2

This answer should be credited to @chili555 who gave the correct answer in his comment above. For others that might be struggling with this here are the steps: First enable/install dkms.

sudo apt-get install dkms

Then here is the sequence of commands I followed:

sudo apt-get install dkms
cd Downloads/
git clone https://github.com/whitebatman2/rtl8821CU.git
cd rtl8821CU/
export DRV_NAME=rtl8821CU
export DRV_VERSION=5.2.5.3
set |grep DRV
sudo mkdir /usr/src/${DRV_NAME}-${DRV_VERSION}
git archive master | sudo tar -x -C /usr/src/${DRV_NAME}-${DRV_VERSION}
cd rtl8821CU/
git archive master | sudo tar -x -C /usr/src/${DRV_NAME}-${DRV_VERSION}
sudo dkms add -m ${DRV_NAME} -v ${DRV_VERSION}
sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
sudo dkms install -m ${DRV_NAME} -v ${DRV_VERSION}
0
0

Updated @chili555's and @Fabio's answer for 2023 (GitHub's default root changed from "master" to "main") and removed duplicate lines.

    sudo apt-get install dkms
    cd Downloads/
    git clone https://github.com/whitebatman2/rtl8821CU.git
    cd rtl8821CU
    export DRV_NAME=rtl8821CU
    export DRV_VERSION=5.2.5.3
    set |grep DRV
    sudo mkdir /usr/src/${DRV_NAME}-${DRV_VERSION}
    git archive main | sudo tar -x -C /usr/src/${DRV_NAME}-${DRV_VERSION}
    sudo dkms add -m ${DRV_NAME} -v ${DRV_VERSION}
    sudo dkms build -m ${DRV_NAME} -v ${DRV_VERSION}
    sudo dkms install -m ${DRV_NAME} -v ${DRV_VERSION}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .