4

This was a problem in 17.10 and it's carried over to 18.04 and at this point it's driving me nuts.

My screen keeps blanking after one minute of idle. I cannot even read articles.

In Gnome settings, Privacy > Lock screen is off, and I've set Power > Blank Screen to Never and Automatic Suspend is set to Off

What else do I need to disable? I'll decide when my screen is locked. I just want all of it off.

Update

Additional things I've checked and ruled out:

I've installed Dconf Editor and checked the settings there and I'm unable to find anything that changes the behaviour. I tried disabling the idle-dim setting under /org/gnome/settings-daemon/plugins/power and tried just disabling the entire power plugin, neither change has had an effect on the behaviour.

I've also combed through the nvidia-settings app and cannot find anything related to power or screen blanking there. My xorg server is using the out-of-the-box auto-detection for startup and there is no xorg.conf setting anything on my system. This is all just default 18.04 behaviour for me.

Found this question and checked the xset q output, adding it. You'll note that my timeout and cycle settings are at 0 which was the solution there, however mine are already set to 0 and my screen is still blanking. That question is for Unity anyway and mine is for Gnome3

routhinator@chris-desktop:~$ xset q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  33
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/Type1,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On

Update No. 2

As per @WinEunuuchs2Unix I have inspected, changed, and reinspected the settings in this question and the issue is still persisting.

On another note, these settings needing to be changed manually like this seems to be a long standing bug that Ubuntu should have fixed long ago, because are these are the exact settings I thought I turned off above in the power settings.

routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout
1800
routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout
3600
routhinator@chris-desktop:~$ gsettings get org.gnome.desktop.screensaver idle-activation-enabled
true
routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power idle-dim
true

routhinator@chris-desktop:~$ gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
routhinator@chris-desktop:~$ gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
routhinator@chris-desktop:~$ gsettings set org.gnome.desktop.screensaver idle-activation-enabled false
routhinator@chris-desktop:~$ gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout
0
routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout
0
routhinator@chris-desktop:~$ gsettings get org.gnome.desktop.screensaver idle-activation-enabled
false
routhinator@chris-desktop:~$ gsettings get org.gnome.settings-daemon.plugins.power idle-dim
false

Update 3

lspci output as requested:

routhinator@chris-desktop:~$ lspci
00:00.0 Host bridge: Intel Corporation 5520/5500/X58 I/O Hub to ESI Port (rev 13)
00:01.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 1 (rev 13)
00:02.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 2 (rev 13)
00:03.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 3 (rev 13)
00:07.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 7 (rev 13)
00:14.0 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub System Management Registers (rev 13)
00:14.1 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers (rev 13)
00:14.2 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub Control Status and RAS Registers (rev 13)
00:14.3 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub Throttle Registers (rev 13)
00:19.0 Ethernet controller: Intel Corporation 82567V-2 Gigabit Network Connection
00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
00:1f.2 IDE interface: Intel Corporation 82801JI (ICH10 Family) 4 port SATA IDE Controller #1
00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
00:1f.5 IDE interface: Intel Corporation 82801JI (ICH10 Family) 2 port SATA IDE Controller #2
01:00.0 IDE interface: Marvell Technology Group Ltd. Device 91a3 (rev 11)
02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
03:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1)
03:00.1 Audio device: NVIDIA Corporation GK106 HDMI Audio Controller (rev a1)
04:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GTX 650] (rev a1)
04:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)
05:00.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6315 Series Firewire Controller (rev 01)
ff:00.0 Host bridge: Intel Corporation Xeon 5500/Core i7 QuickPath Architecture Generic Non-Core Registers (rev 05)
ff:00.1 Host bridge: Intel Corporation Xeon 5500/Core i7 QuickPath Architecture System Address Decoder (rev 05)
ff:02.0 Host bridge: Intel Corporation Xeon 5500/Core i7 QPI Link 0 (rev 05)
ff:02.1 Host bridge: Intel Corporation Xeon 5500/Core i7 QPI Physical 0 (rev 05)
ff:03.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller (rev 05)
ff:03.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Target Address Decoder (rev 05)
ff:03.4 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Test Registers (rev 05)
ff:04.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Control Registers (rev 05)
ff:04.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Address Registers (rev 05)
ff:04.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Rank Registers (rev 05)
ff:04.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Thermal Control Registers (rev 05)
ff:05.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Control Registers (rev 05)
ff:05.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Address Registers (rev 05)
ff:05.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Rank Registers (rev 05)
ff:05.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Thermal Control Registers (rev 05)
ff:06.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Control Registers (rev 05)
ff:06.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Address Registers (rev 05)
ff:06.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Rank Registers (rev 05)
ff:06.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Thermal Control Registers (rev 05)
  • Please post the output of lspci – eyoung100 Nov 14 '18 at 4:25
  • Done as requested. Check Update 3 – Routhinator Nov 14 '18 at 21:18
  • Are you trying to use them as SLI devices? If so, your problem is that one is a 650 (106) and one is a 660(107). The issue occurs because the clock speeds are different – eyoung100 Nov 17 '18 at 23:34
  • Not using them as SLI. Second card was added for experimental use with crypto currency only. Only the 660 is configured and used for Video. – Routhinator Nov 21 '18 at 23:51
1

I also had issues with this happening, on a machine that has Ubuntu 18.04 Desktop installed, but is in fact being used as a server. As such the screen blanked, and wouldn't come back. Eventually, I figured out that it was actually caused by the sleep settings kicking in.

Since the machine used LXDE, and didn't have Gnome installed at all, none of the suggestions that I found mentioning gsettings etc. could be used. Eventually I was led to the sleep settings, independent of the login/window manager in use.

So, in addition to the gsettings solutions listed in prior posts, test this solution by disabling the sleep service, and see if it removes the problem:

sudo systemctl mask sleep.target

To undo the change:

sudo systemctl unmask sleep.target

For what it is worth, I also disabled suspend.target, hibernate.target and hybrid-sleep.target to prevent any unwanted behaviour.

  • Is a reboot required to apply this? Seems like it would be. Trying this to see if it rectifies my issue. – Routhinator Oct 1 '19 at 20:18
  • Disabled all of them and rebooted, unfortunately with no change in behaviour. – Routhinator Oct 1 '19 at 22:59
  • @Routhinator: Assuming that Caffeine approach etc. doesn't work... something else... monitor has a build-in energy saver blanking feature, on "no video", accessed via OSD -> menu -> timer -> 20s. Perhaps monitor is incorrectly detecting the video signal, and applies it's internal blanking function. Change the timer, if you have that setting, or disable energy saving on the monitor itself, and see if that changes anything? – sarlacii Oct 2 '19 at 12:08
  • Good thinking, however I have two monitors on this pc and they both blank in unison. It's definitely something in linux doing it. It doesn't happen in Win10 on the same box. – Routhinator Oct 2 '19 at 13:09
  • So Far so Good, but I will tell you if it worked for sure, otherwise the 3-4 options below look VERY promising ... but I will wait on that until it's needed – markackerman8-gmail.com Nov 13 '19 at 20:26
0

I had similar issues until I installed a gnome extension called "caffeine" available via the software app.

  • This can be a workaround, but it comes with caveats. For example, unless something has changed with Caffeine, it will prevent your chat applications from detecting or displaying away statuses. – Routhinator Nov 7 '18 at 0:50
0

This Q&A seems to describe your situation: Screen turning off when idle even with power settings disabled

To summarize the answer there first discover your options:

gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout
gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout
gsettings get org.gnome.desktop.screensaver idle-activation-enabled
gsettings get org.gnome.settings-daemon.plugins.power idle-dim

Then set them with:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 0
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
gsettings set org.gnome.desktop.screensaver idle-activation-enabled false
gsettings set org.gnome.settings-daemon.plugins.power idle-dim false
  • It will be interesting if that is the issue and I'll have to open a bug with Ubuntu, as this is a desktop and there is no battery, so idle-dim should not be active. – Routhinator Nov 10 '18 at 21:39
  • Waiting to confirm, but all of those settings were active so I flipped them as advised. – Routhinator Nov 10 '18 at 21:40
  • Failed, these settings are changed, however the issue is still occurring. – Routhinator Nov 10 '18 at 22:21
  • Another workaround might be to completely uninstall nvidia drivers and try to use the open-source nouveau. If you search across the web, if you didn't already, you will find many similar problems with yours, dealing with Nvidia drivers and Ubuntu 18.04. I suppose this is a problem with Nvidia drivers and GNOME3 on Ubuntu 18.04. askubuntu.com/questions/1067559/… – NickTux Nov 10 '18 at 22:43
  • That issue is different than mine, the OP is complaining about the screen remaining black after it's been blanked, mine is just being blanked. It comes back fine, and the NVIDIA drivers are 10x faster and less glitchy than the nouveau drivers. – Routhinator Nov 10 '18 at 23:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.