11

Last night I thought to check whether Canonical Livepatch service is working fine after upgrading to Ubuntu 18.10 from Ubuntu 18.04. I know it was meaningless since it was working fine in Ubuntu 18.04. But to my surprise when I ran

sudo canonical-livepatch status --verbose

I got the error:

2018/11/03 23:11:05 error executing status: Livepatchd error: The platform Ubuntu 18.10 is not supported. exiting.

I am now confused, is the problem only on my system? OR Is Canonical Livepatch service not supported on Ubuntu 18.10?

I would therefore like to request my fellow Ubuntu 18.10 users to do the check and if someone knows the reason/solution please reply to this thread.

2
  • Use LTS, @overkill! And live 5 years without pain. – N0rbert Nov 3 '18 at 20:01
  • 4
    well, I would like to live on the bleeding edge rather than stay secure @N0rbert.But never the less thanks for your quick response. – overkill Nov 7 '18 at 16:27
15

As per this (old) documentation,

The Canonical Livepatch Service applies kernel fixes in microseconds, without restarting your Ubuntu LTS system.

and

The Canonical Livepatch Service applies security critical Linux kernel patches without rebooting, keeping your Ubuntu LTS systems secure and compliant.

(emphasis mine)

Also as per System Requirements in this Ubuntu wiki article, currently supported releases are Ubuntu 14.04 LTS , Ubuntu 16.04 LTS, and Ubuntu 18.04 LTS.

Since Ubuntu 18.10 is not an LTS release, it's not very surprising that it's not supported.

2
  • Thanks! And i think you are correct @pomsky.But really it does not make sense not supporting the non-lts versions for livepatch........ – overkill Nov 7 '18 at 16:31
  • 2
    @overkill Actually it does - Non-LTS releases are only supported for 9 months, LTSes are supported for 5 years. Usually the systems needing the LivePatch system would be systems that don't turn off ever (read: servers) that are running LTSes in most cases. – Thomas Ward Mar 5 '20 at 15:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.