14

I'm trying to install KVM\qemu on Ubuntu 18.10.

According to this page I'm running the command:

apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils

and get an error about the packge "libvirt-bin" and "ubuntu-vm-builder":

E: Package 'libvirt-bin' has no installation candidate
E: Unable to locate package ubuntu-vm-builder

I see that the package "libvirt-bin" is available.

The main repository is set. Anything that I'm doing wrong? Couldn't find any info regrading this issue.

Is it the new Ubuntu version (18.10)?

Thanks

19

You are correct: The libvirt-bin package was dropped in 18.10.

Quoting from https://lists.debian.org/debian-user/2016/11/msg00518.html

The package was split into two parts:

libvirt-daemon-system

libvirt-clients

In most cases you probably want both of them at the same time.

so instead of libvirt-bin use libvirt-daemon-system libvirt-clients

  • The clarification is because this was used as a dupe (so upvoted) and the other user didn't understand... – Fabby Nov 8 '18 at 10:53
  • 1
    I've updated the ubuntu wiki – Rwky Nov 19 '18 at 16:50
  • 1
    working on 19.04, thanks – Meloman Sep 5 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.