2

I want to install Screenlets and I tried the following bash:

#!/bin/bash
sudo dpkg -l python-wnck >/dev/null 2>&1
if [ $? == 0 ]; then
  echo "OK"
else
  echo "Install python-wnck"
  sudo apt -y install libwnck22
  wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnome-python-desktop/python-wnck_2.32.0+dfsg-4_amd64.deb
  sudo dpkg -i python-wnck_2.32.0+dfsg-4_amd64.deb
  sudo apt --fix-broken -y install
fi
sudo dpkg -l python-gnomekeyring >/dev/null 2>&1
if [ $? == 0 ]; then
  echo "OK"
else
  echo "Install python-gnomekeyring"
  wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnome-python-desktop/python-gnomekeyring_2.32.0+dfsg-4_amd64.deb
  sudo dpkg -i python-gnomekeyring_2.32.0+dfsg-4_amd64.deb
  sudo apt --fix-broken -y install
fi
sudo add-apt-repository -y ppa:screenlets/ppa
sudo sed -i 's/bionic/xenial/g' /etc/apt/sources.list.d/screenlets-ubuntu-ppa-bionic.list
sudo apt update && sudo apt -y install screenlets screenlets-pack-all

But all I get is this:

tobi@tobi-System-Product-Name:~$ #!/bin/bash
tobi@tobi-System-Product-Name:~$ sudo dpkg -l python-wnck >/dev/null 2>&1
tobi@tobi-System-Product-Name:~$ if [ $? == 0 ]; then
>   echo "OK"
> else
>   echo "Install python-wnck"
>   sudo apt -y install libwnck22
>   wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnome-python-desktop/python-wnck_2.32.0+dfsg-4_amd64.deb
>   sudo dpkg -i python-wnck_2.32.0+dfsg-4_amd64.deb
>   sudo apt --fix-broken -y install
> fi
OK
tobi@tobi-System-Product-Name:~$ sudo dpkg -l python-gnomekeyring >/dev/null 2>&1
tobi@tobi-System-Product-Name:~$ if [ $? == 0 ]; then
>   echo "OK"
> else
>   echo "Install python-gnomekeyring"
>   wget -c http://archive.ubuntu.com/ubuntu/pool/universe/g/gnome-python-desktop/python-gnomekeyring_2.32.0+dfsg-4_amd64.deb
>   sudo dpkg -i python-gnomekeyring_2.32.0+dfsg-4_amd64.deb
>   sudo apt --fix-broken -y install
> fi
OK
tobi@tobi-System-Product-Name:~$ sudo add-apt-repository -y ppa:screenlets/ppa
sudo: unable to execute /usr/bin/add-apt-repository: No such file or directory
tobi@tobi-System-Product-Name:~$ sudo sed -i 's/bionic/xenial/g' /etc/apt/sources.list.d/screenlets-ubuntu-ppa-bionic.list
sed: can't read /etc/apt/sources.list.d/screenlets-ubuntu-ppa-bionic.list: No such file or directory
tobi@tobi-System-Product-Name:~$ sudo apt update && sudo apt -y install screenlets screenlets-pack-all
Get:1 http://archive.getdeb.net/ubuntu xenial-getdeb InRelease
Err:1 http://archive.getdeb.net/ubuntu xenial-getdeb InRelease                                                                             
  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
Get:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]                                                                 
Ign:3 http://ppa.launchpad.net/inameiname/stable/ubuntu bionic InRelease                                                                   
Hit:4 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu bionic InRelease                                                                
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial InRelease                                                                                 
Err:6 http://ppa.launchpad.net/inameiname/stable/ubuntu bionic Release                                                                     
  404  Not Found [IP: 91.189.95.83 80]
Get:7 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]                                                      
Hit:8 https://download.sublimetext.com apt/dev/ InRelease                                                            
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]                                        
sh: 1: /usr/lib/cnf-update-db: not found                  
Reading package lists... Done
E: Failed to fetch http://archive.getdeb.net/ubuntu/dists/xenial-getdeb/InRelease  Clearsigned file isn't valid, got 'NOSPLIT' (does the network require authentication?)
E: The repository 'http://archive.getdeb.net/ubuntu xenial-getdeb InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://ppa.launchpad.net/inameiname/stable/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code
tobi@tobi-System-Product-Name:~$ 

I think sudo apt-get update doesn't work for me, but I don't know how I can fix this.


output of apt-cache policy python3-software-properties:

python3-software-properties:
  Installed: 0.96.24.32.4
  Candidate: 0.96.24.32.4
  Version table:
 *** 0.96.24.32.4 100
        100 /var/lib/dpkg/status
     0.96.20.7 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages
     0.96.20 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages
0

The add-apt-repository command is located in software-properties-common. You need to install it first:

sudo apt-get install software-properties-common

Then you may want to remove or edit paths for problematic PPAs:

  1. GetDeb.net is often down. You should follow this answer and edit corresponding sources.list.

  2. The inameiname/stable PPA does not have files for Bionic (but have for Xenial). You should edit its sources.list and change bionic to xenial.

Then you will be able to update package lists and retry your procedure.

As the result you will get ScreenLets installed and can configure them with screenlets:

ScreenLets Manager


Note: for Ubuntu 16.04 LTS one can use official PPA - ppa:screenlets/ppa.

  • I'm getting this error: E: The package python3-software-properties needs to be reinstalled, but I can't find an archive for it. – Tobi696 Nov 3 '18 at 16:21
  • Then please add output of apt-cache policy python3-software-properties to the question. – N0rbert Nov 3 '18 at 16:23
  • I have added it. – Tobi696 Nov 3 '18 at 16:27
  • Install normal version with sudo apt-get install --reinstall python3-software-properties=0.96.20.7. – N0rbert Nov 3 '18 at 17:49
  • E: The package python3-software-properties needs to be reinstalled, but I can't find an archive for it. (same error again) – Tobi696 Nov 3 '18 at 18:00
0

I was not able to follow the guide above. But with this video-tutorial I was able to do it. It is in spanish, and I don't speak Spanish (not a word), yet it is easy to follow what he type into terminal etc.

Como personalizar Ubuntu 18.04 LTS con Screenlets - Parte 3 https://www.youtube.com/watch?v=DMXSZ7tVkyM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.