36

I am using Ubuntu 11.10. This seems to be an easy question, yet I cannot find an answer anywhere.

On pre-unity Ubuntu, I was using gedit-zoom plugin to zoom text in editor window in/out, either with Ctrl++/-, or by holding Ctrl+ scrolling mouse-wheel. The same plugin does not seem to work in Ubuntu 11.10.

Any way I can get text zooming capability?

1
  • 1
    The functionality appears to be broken in 12.04. Ctrl+"-" and Ctrl+"0" work, while Ctrl+"+" and Ctrl+mousewheel do not.
    – Greg V.
    May 15, 2012 at 12:51

3 Answers 3

48

v2screenshot

  1. Under EditPreferencesPlugins, you can tick the Text Size box and zoom in with ctrl++.

    • Click on gedit-plugins Install gedit-plugins to install the Gedit plugins.

    • You can also manually download/install the plugin.

  2. ctrl+Trackpad scroll (up/down) enables you, to zoom in and out as well, not only within gEdit, but also in your Webbrowser, File System etc.

Both possibilities work just fine in Ubuntu 11.10.


Update information for Ubuntu 17.x.x, 18.x.x and later, as suggested by code_dredd - tested and works:

sudo apt-get install -y gedit-plugin-text-size

enter image description here

13
  • 1
    I don't have the plugin you mentioned in here.
    – jokerdino
    Mar 1, 2012 at 6:03
  • 1
    That was a hint to tell you to add the part about installing the plugin. ;)
    – jokerdino
    Mar 1, 2012 at 6:19
  • 1
    indeed it was (: ftp.gnome.org/pub/gnome/sources/gedit-plugins however doesn't seem to work right now, but you can also type in "gedit" in "Ubuntu Software Center" and add plugins from there.
    – v2r
    Mar 1, 2012 at 6:27
  • 8
    These steps no longer work on Ubuntu 17.10. The gedit-plugins package does not include the gedit-plugin-text-size package with it. You now have to install the package manually: sudo apt-get install -y gedit-plugin-text-size.
    – code_dredd
    Mar 22, 2018 at 15:34
  • 2
    Thank you code_dredd! I added your suggestion to my original answer. Both links are working fine now: Sunday, May 5th 2019; 9:42:37 AM
    – v2r
    May 5, 2019 at 8:04
5

enter image description hereYou can change the fontsize in the preferences menu under the fonts tab

2
  • Maybe this is the only 'official' way. But, we are always looking for the fastest way, aren't we? May 18, 2016 at 7:24
  • Thanks this worked for me since I don't have the plugin! +1
    – ocean800
    Jul 15, 2016 at 3:45
1

I didn't see "Text size" plugin in the list of the plugins when I opened Preferences->Plugins even after installing gedit-plugins package(via apt install) and restarting gedit few times. So, I downloaded manually the corresponding deb file(gedit-plugin-text-size_3.22.0-2_amd64.deb) from the launchpad (http://launchpadlibrarian.net/335063179/gedit-plugin-text-size_3.22.0-2_amd64.deb) for my Ubuntu 17.10 x86_64 and installed it, restarted gedit and saw "Text size" plugin thereafter in the list. Enabled it and finally got the zoom-in/out feature with mouse-scroll-wheel I much needed.

Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.