I have two monitors set up using Nvidia Twinview on Ubuntu 11.10.

When I drag something (a file, a link on a website, select text, etc.), my right-hand monitor screws up. Usually the screen shifts up by about 200 pixels, and I often get weird graphics glitches.

I made a video here which is kind of grainy, but shows what happens. The video doesn't exactly show what I see because during the first 12 seconds, when dragging from the left monitor, the right monitor screws up like in the last 12 seconds.

This doesn't happen when dragging windows, only objects like files or hyperlinks. Sometimes my desktop gets stuck like that, which is really frustrating.

My graphics card is an NVidia GTX 460 SE. I've had this problem for some time, but I definitely know there was a time when I had two monitors and this didn't happen.





>lspci -nn | grep VGA
>03:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0e23] (rev a1)

I'll also include a screenshot which basically shows what's in the video.

enter image description here

Based on fossfreedom's advice, I tried installing the 295 drivers from the ubuntu-x-swat ppa. I follow the instructions here which didn't install them.

I made sure I was booting into kernel 3.0.0-16 (before I was using 3.0.0-12) and reinstalled again to no avail.

The reinstall command says it's installing the 295 drivers, but they're not getting installed for some reason.

  • We need more hardware information to help you, can you look at this question and then edit your question adding the information. Please include your version of Ubuntu – Ringtail Mar 1 '12 at 3:05
  • @BlueXrider I added the output of various commands listed in that question. Please tell me what other hardware information might be helpful. – Kris Harper Mar 1 '12 at 3:21
  • @root45 - which driver did you install i.e. did you install the driver as shown in this Q&A (askubuntu.com/questions/76016/…) (n.b. try enabling software sources backports, update and then reopen Additional Drivers). Alternatively have you tried the v295 nvidia driver as per this answer (it has a ppa-purge command as well if it goes wrong! askubuntu.com/questions/111818/…) – fossfreedom Mar 13 '12 at 23:29
  • @fossfreedom Yes, I have the Nvidia post-release updates installed and am using Twinview like in the question you posted. I've added my Xorg.conf, which is pretty much the same as in that question. I also added the ppa in the second question, but nvidia-current-modaliases doesn't seem to be in that ppa. I added the other two packages, but they didn't update me to v295. As for enabling backports, I think they're already enabled on 11.10. In software sources I have "unsupported updates" checked. – Kris Harper Mar 14 '12 at 0:29
  • ignore the nvidia-current-modaliases - you are correct (it isnt used in oneiric anymore) - just install nvidia-current and nvidia-settings – fossfreedom Mar 14 '12 at 13:50

Try to upgrade your nvidia driver with:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current nvidia-current-modaliases nvidia-settings

I have noticed you use 280 version of Nvidia drivers. In the above repos you will find the latest drivers and the latest version of the X server. Possibly it will fix the issues.

If anything goes wrong, you can revert with

sudo ppa-purge ppa:ubuntu-x-swat/x-updates

Friendly note from Oli: I've removed xorg-edgers from the answer above but if you find that ubuntu-x-swat doesn't get you anywhere you could try ppa:xorg-edgers/ppa which is an even more updated version of the graphics stack. You should be aware that while x-swat is mainly driver updates, edgers will try to replace the whole kit and kaboodle. It will probably eat your babies.

  • its looks like you have cobbled together two competing PPAs - are you sure you know what you are asking the OP to-do?! - xorg-edgers is not a PPA you should use if you dont know how to reverse black screens etc. – fossfreedom Mar 10 '12 at 19:29
  • FossFreedom has a good point. If I install the drivers from xorg-edgers and I get a black screen on boot up, how can I revert to my old drivers? Will running the ppa-purge command from a TTY automatically install the old drivers? – Kris Harper Mar 11 '12 at 19:32

ok, thinking this through ... you mentioned that you had activated the Post Release updates NVIDIA driver through the Additional Drivers window.

Behind the scenes this would have installed the nvidia-current-update package.

By installing the X-Swat package - this gives you a new nvidia-current package but as you can see, your nvidia-current-update package is taking precedent.


Please image your computer - messing about with graphics drivers can leave you with non-booting & black screen issues. If you are not confident with resolving this through the recovery mode and terminal, then either do not proceed or have an image that you can readily restore.


Now the warning is explained - deactivate the Post Update driver in Additional Drivers window. Rename you current xorg.conf file and reboot


sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

You should now be using the default opensource nouveau drivers.

Next, purge your old nvidia packages:

sudo apt-get purge nvidia-*


Next add the X-Swat PPA:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-current nvidia-settings

Reopen your Additional Drivers window and activate the NVidia Current driver.


Check through gksudo nvidia-settings - you should now be using the v295 driver set.

Set your twin monitors as per this Q&A:

Dual monitors not working with an Nvidia card

Hopefully now your issue is now resolved.

If it is not resolved - then the nvidia driver is not the key problem here but instead is either Compiz and/or the kernel itself.

Given the imminent 12.04 release in a months time, it will come with the latest Compiz and kernel and therefore could/should resolve your issue.

I'm reluctant to recommend you pursuing the x-org-edgers PPA route - to do this you should install the Kernel in the PPA as well as the recommended packages itself.

If you want to upgrade to 12.04 beta - remember you will be helping out the developers with testing. There are other bugs that you could have to contend with. The developers are very keen for testers to test with the 12.04 multimonitor support! Therefore - if your issue is not immediately resolved with 12.04 - at least the developers should be much more keener to help you resolve this via filing launchpad.net bug reports.

  • I just tried this an unfortunately it still didn't update me to the 295 drivers. When I upgrade to 12.04, do you think the drivers will update as well? I guess it's difficult to say since this should have installed them as well. – Kris Harper Mar 15 '12 at 22:45
  • damn - that should have fixed it. Yes, 12.04 comes with the latest (packages.ubuntu.com/…) together with the 3.2 kernel. – fossfreedom Mar 15 '12 at 22:56
  • @root45 - one more try - I've added a purge statement in my answer. This will make sure all remnants of the nvidia packages are deleted before you install the PPA. – fossfreedom Mar 15 '12 at 22:59
  • That worked! Unfortunately, I still have the the dragging issue. Not a big deal though. I can wait for 12.04 to see if it gets fixed. – Kris Harper Mar 15 '12 at 23:45
  • One question though. There's a new driver in the additional drivers view called Nvidia binary Xorg driver, kernel module and VDPAU library. I'm not sure what that is? – Kris Harper Mar 15 '12 at 23:46

In the past, I have had similar problems when both monitors did not match in geometry. Some references I have seen suggest they should be matched in scan rate as well, e.g., the same model of monitor. When I had one installation messing this up, with two different monitor sizes, the problem mostly went away after I forced my higher resolution monitor down to the same resolution as the smaller monitor. Don't know if this is the case for you, but it is probably necessary to at least run the same resolution on both for debugging.

  • I don't know if that will work. The resolution of the smaller monitor isn't available as an option for the larger monitor. – Kris Harper Mar 4 '12 at 17:49

I upgraded to 12.04 and the problem seems to have been resolved.

Note that I am not using any additional drivers. The standard drivers for 12.04 seem to be fine for me, allowing 3D effects, full Unity experience, etc. They even allow me to rotate my monitors individually, which is something I could not accomplish with Nvidia.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.