0

I have two different PCs, each multi-boot, with Ubuntu 18.04 as one of the operating systems on each. When I run the 18.10 upgrade on either machine, it appears to be fully processing the upgrade, but when I reboot, it still says I'm on 18.04. I've tried it both thru the GUI and thru the terminal, same result. What gives? Oddly, the report seems to show a completed upgrade, but under System>Details, it still says it's the last version (see screenshot).

dave@BigBoy:~$ ubuntu-report show

{ "Version": "18.10", "OEM": { "Vendor": "To Be Filled By O.E.M.",

"Product": "To Be Filled By O.E.M." },

"BIOS": { "Vendor": "American Megatrends Inc.",

"Version": "P1.30" },

"CPU": { "OpMode": "32-bit, 64-bit",

"CPUs": "4",
"Threads": "1",

"Cores": "4",

"Sockets": "1",

"Vendor": "AuthenticAMD",

"Family": "16",

"Model": "4",

"Stepping": "3",

"Name": "AMD Phenom(tm) II X4 955 Processor",

"Virtualization": "AMD-V"

},

"Arch": "amd64", "GPU": [

{ "Vendor": "10de", "Model": "1244" }

], "RAM": 32.9, "Disks": [ 240.1, 2000.4, 2000.4, 320.1, 0, 0, 0, 0, 0, 0, 0, 15.6 ],

"Partitions": [ 19.5, 1, 15.2 ],

"Screens": [

{ "Size": "598mmx336mm", "Resolution": "1920x1080", "Frequency": "60.00" }

], "Autologin": true, "LivePatch": false, "Session": { "DE": "Unity:Unity7:ubuntu", "Name": "unity", "Type": "x11" },

"Language": "en_US",

"Timezone": "America/New_York",

"Upgrade": {

"From": "18.04",

"InstallMedia": "Ubuntu 14.04.3 LTS \"Trusty Tahr\" - Beta amd64 (20150805)",

"Type": "GTK",
"ThirdPartySources": false,
"Stages": {

  "0": "start",

  "6": "PREPARE",

  "22": "MODIFY_SOURCES",

  "75": "FETCH",

  "193": "INSTALL",

  "199": "INSTALL",

  "356": "INSTALL",

  "15163": "POSTUPGRADE",

  "15370": "CLEANUP",

  "20526": "REBOOT"
}

}

dave@BigBoy:~$ ubuntu-report show | grep Version

"Version": "18.10",

"Version": "P1.30"

screenshot of system>details after upgrade

During the upgrade process, I did note some oddities toward the end (I often leave the terminal window open, and monitor it), where it would begin some process, hesitate, then come back with an error message about "no swap area available", when in fact I have about 8GB set aside specifically for swap. That happened 4 or 5 times, near the end of the process. After that, the upgrade finally acted as if it was finished and asked for a restart, but on rebooting and seeing that "18.04" still showing, I wasn't so sure everything had finished properly -- or if it had chickened out and reverted me to 18.04.

  • P;ease edit your question to include the complete output of ubuntu-report show | grep Version – user535733 Nov 3 '18 at 3:19
  • So your problem is with the logo only? – Rinzwind Nov 3 '18 at 16:52
  • It sounds even sillier when you put it that way, but if the upgrade did complete the way it should, why is it not reflected in system>details? – djroff Nov 3 '18 at 19:08
  • What do you get with lsb_release -cdir? – AlexP Nov 3 '18 at 21:12
  • ~$ lsb_release -cdir Distributor ID: Ubuntu Description: Ubuntu 18.10 Release: 18.10 Codename: cosmic ......which all looks good, so why the discrepancy elsewhere? – djroff Nov 3 '18 at 21:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.