2

I am using Gparted to create partitions in order to set up a RAID5 between 4x4TB drives. I managed to set up 3 of the drives using gparted with no problem, but I have had a lot of issues with this last drive. Every time I try to create a partition after making a partition table, it throws an error (in both disks, and gparted). Here is the exact error I get:


GParted 0.30.0 --enable-libparted-dmraid --enable-online-resize

Libparted 3.2
Create Primary Partition #1 (ext4, 3.64 TiB) on /dev/sdd  00:00:14    ( ERROR )

create empty partition  00:00:00    ( SUCCESS )

path: /dev/sdd1 (partition)
start: 2048
end: 7814035455
size: 7814033408 (3.64 TiB)
clear old filesystem signatures in /dev/sdd1  00:00:00    ( SUCCESS )

write 512.00 KiB of zeros at byte offset 0  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 67108864  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 274877906944  00:00:00    ( SUCCESS )
write 512.00 KiB of zeros at byte offset 4000784580608  00:00:00    ( SUCCESS )
write 4.00 KiB of zeros at byte offset 4000785039360  00:00:00    ( SUCCESS )
write 8.00 KiB of zeros at byte offset 4000785096704  00:00:00    ( SUCCESS )
flush operating system cache of /dev/sdd  00:00:00    ( SUCCESS )
set partition type on /dev/sdd1  00:00:00    ( SUCCESS )

new partition type: ext4
create new ext4 filesystem  00:00:14    ( ERROR )

mkfs.ext4 -F -O ^64bit -L '' '/dev/sdd1'  00:00:14    ( ERROR )

64-bit filesystem support is not enabled. The larger fields afforded by this feature enable full-strength checksumming. Pass -O 64bit to rectify.
Creating filesystem with 976754176 4k blocks and 244195328 inodes
Filesystem UUID: 8644ed3d-e649-471b-9389-8cae17ea67db
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
102400000, 214990848, 512000000, 550731776, 644972544

Allocating group tables: done
Writing inode tables: done
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information:
mke2fs 1.44.1 (24-Mar-2018)

Warning, had trouble writing out superblocks.

========================================

After this, the disk is unreadable until I reboot the computer. I have tried SMART tests, which show no error, and have tried to create this partition about 3 times now. Does anyone have any suggestions or should I call it a day and put in a request for a replacement drive?

Thanks.

  • Lay down a fresh GPT partition table (this will wipe the drive), then create a MSDOS or NTFS or any other file system. Then delete that partition, and see if it'll then allow you to create an ext4 partition. – heynnema Nov 3 '18 at 0:14
  • @heynnema great. I will try that now. I'm very new to this stuff. Thanks. – Harri Taylor Nov 3 '18 at 12:52
0

@heynnema hit the nail in the comment. Can confirm it worked for me.

The solution is to format it as different partition type (in my case NTFS). Notice you need to apply changes after that. Than delete NTFS partition and format it as ext4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.