1

I use the Disks application (preinstaled in Ubuntu 18.04) to configure standby timeout of my HDD disk. By using the Drive settings... -> Standby menu I've configured Standby Timeout to 15min. The disk goes into standby after 15min of idle state only if I disable S.M.A.R.T. monitoring by using the SMART Data & Self-Tests menu. By using the sudo hdparm -y /dev/sdb command I can force the disk into standby regardless the SMART monitoring is turned on or off.

I want to have SMART monitoring and Standby timeout both enabled, but the features seem to collide with each other.

Is there any way to fix the problem without excess hacking?

1
  • Some HDD have a "spin down when idle" parameter internal to the drive. You can check your drive, and try and set it there. – heynnema Nov 2 '18 at 12:37
0

You should get a monitoring time greater than your standby timeout. As each request to smart attributes reinit the time out.

If you query your smart attributes every hour, a 15 minutes timeout could occurs. If you query your smart attributes every hour, a 2 hours timeout never occurs.

2
  • How to make the monitoring timeout greater than the standby timeout? – user7547272 Mar 18 '19 at 15:21
  • I don't know you tool. Mine is cacti where I could define the time between to control. You should use hdparm to control the disk state in order to do not wake it up. en.wikipedia.org/wiki/Hdparm I'm not on ubuntu so I can't help more. I just can explain why it occurs. – Taryck B. Mar 19 '19 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.