0

after upgrading to 18.10 DNS configured in my cisco anyconnect compatible VPN seems to be ignored. I'm just getting some errors like "systemd-resolved[939]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP" in syslog Any idea what does it mean?

EDIT:

1) no-VPN:

mirec@p50:~/tmp$ ps auxc | grep -i dns
mirec     6036  0.0  0.0 334772  7936 ?        Sl   12:04   0:00 gvfsd-dnssd
mirec@p50:~/tmp$ ps auxc | grep -i resolv
systemd+   939  0.0  0.0  54956  8664 ?        Ss   10:31   0:06 systemd-resolve
mirec@p50:~/tmp$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=122 time=8.84 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=122 time=9.05 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=122 time=8.03 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=122 time=9.21 ms
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 8.028/8.781/9.205/0.458 ms
mirec@p50:~/tmp$ ping www.ebay.com
PING e9428.b.akamaiedge.net (23.211.9.229) 56(84) bytes of data.
64 bytes from a23-211-9-229.deploy.static.akamaitechnologies.com (23.211.9.229): icmp_seq=1 ttl=54 time=38.1 ms
64 bytes from a23-211-9-229.deploy.static.akamaitechnologies.com (23.211.9.229): icmp_seq=2 ttl=54 time=38.5 ms
64 bytes from a23-211-9-229.deploy.static.akamaitechnologies.com (23.211.9.229): icmp_seq=3 ttl=54 time=38.1 ms
64 bytes from a23-211-9-229.deploy.static.akamaitechnologies.com (23.211.9.229): icmp_seq=4 ttl=54 time=37.4 ms
64 bytes from a23-211-9-229.deploy.static.akamaitechnologies.com (23.211.9.229): icmp_seq=5 ttl=54 time=36.8 ms
^C
--- e9428.b.akamaiedge.net ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 11ms
rtt min/avg/max/mdev = 36.767/37.779/38.521/0.626 ms

2) VPN-connected:

mirec@p50:~/tmp$ ps auxc | grep -i dns
mirec     6036  0.0  0.0 334772  7936 ?        Sl   12:04   0:00 gvfsd-dnssd
mirec@p50:~/tmp$ ps auxc | grep -i resolv
systemd+   939  0.0  0.0  54956  8664 ?        Ss   10:31   0:06 systemd-resolve
mirec@p50:~/tmp$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=122 time=8.75 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=122 time=8.84 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=122 time=9.25 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=122 time=8.61 ms
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 8ms
rtt min/avg/max/mdev = 8.611/8.860/9.246/0.263 ms
mirec@p50:~/tmp$ ping www.ebay.com
PING e9428.b.akamaiedge.net (23.53.174.111) 56(84) bytes of data.
64 bytes from a23-53-174-111.deploy.static.akamaitechnologies.com (23.53.174.111): icmp_seq=1 ttl=53 time=23.1 ms
64 bytes from a23-53-174-111.deploy.static.akamaitechnologies.com (23.53.174.111): icmp_seq=2 ttl=53 time=23.1 ms
64 bytes from a23-53-174-111.deploy.static.akamaitechnologies.com (23.53.174.111): icmp_seq=3 ttl=53 time=22.3 ms
64 bytes from a23-53-174-111.deploy.static.akamaitechnologies.com (23.53.174.111): icmp_seq=4 ttl=53 time=24.8 ms
^C
--- e9428.b.akamaiedge.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 7ms
rtt min/avg/max/mdev = 22.251/23.324/24.847/0.951 ms
  • 1
    Edit your question to include the output of ps auxc | grep -i dns and ps auxc | grep -i resolv and cat /etc/fstab and ping 8.8.8.8 and ping www.ebay.com. Try them with/without VPN up. Report back to @heynnema – heynnema Nov 1 '18 at 18:46
  • Hi @heynnema, I added requested info – mirec Nov 1 '18 at 19:44
  • Oops, silly me. I asked for the output of cat /etc/fstab when I should have asked for cat /etc/resolv.conf. I edited the /etc/fstab out of your question for you. Please check the contents of the /etc/resolv.conf file with/without VPN... I suspect it'll be 127.0.0.53 both times. Do you what DNS servers that you're using with/without VPN? If so, what are they? When you connect to VPN, do you use a .ovpn file, or an app? – heynnema Nov 1 '18 at 20:07
  • yeah, that's exactly what's there regardless of no-VPN or VPN-connected: nameserver 127.0.0.53 – mirec Nov 1 '18 at 20:11
  • I added three more questions in the last comment... plz take a look for me. Also, tell me how you know that the VPN DNS server is not being used. – heynnema Nov 1 '18 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.