0

I‘m trying to launch firefox and it tells me, there‘d already be a firefox process running.
I tried listing the processes using ps -A, but there is no firefox process listed. I also tried killall -9 firefox and pkill firefox, and neither worked. killall also prompted me that there is no firefox process and pkill didnt say anything. Any other suggestions?

PS: sorry for no code highlighting, im on my phone and can‘t add those dashes here :/

1
  • I found a solution now in unix.stackexchange.com/questions/78689/… . Not sure, if I should delete the question now, because it's a duplicate, or if I should link to unix.stackexchange in an answer because it's another stackexchange network?! – Max Nov 1 '18 at 12:32
0

Most probably your Firefox profile is locked. If newly starting Firefox discovers profile is locked it assumes another copy is running and show this error. Lock file normally removed on Firefox shutdown, but, sometimes, in case of crash or power outage it may remain and cause problems.

Profile is located at ~/.mozilla/firefox/*somestring*.default/ and lock file is called .parentlock

You need to remove this file and start Firefox.

1
  • Oh, sorry, you found solution already. Gotta read comments. – Kuribo Kutsu Nov 1 '18 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.