0

I am posting this thread after trying all the solutions provided in the forums but it does not work for me.

These are the step that I have taken:

1- installed Ubuntu 18.04 LTS (with all the updates)

2- wifi not working, so I run sudo apt purge bcmwl-kernel-source ,reboot, then run sudo apt-get install bcmwl-kernel-source

The Wifi started working, but when I reboot the computer it stops working again.

I added these to /etc/modprobe.d/blacklist.conf but still no luck:

-blacklist brcmsmac

-blacklist bcma

-blacklist ssb

-blacklist b43

what exactly am I doing wrong?

Thanks.

  • Please edit your question to add the result of the terminal commands: lspci -nnk | grep 0280 -A3 and also: sudo modprobe wl Welcome to Ask Ubuntu. – chili555 Nov 1 '18 at 12:53
0

I finally found the solution.

It's weird but it was a simple grub update.

"wl" was the driver that worked for me after installing the bcmwl-kernel-source. the problem is that the installation modifies /boot/initrd.img-4.15.0-38-generic so that the driver that would be detected after reboot would stay wl, however my OS was booting from /boot/initrd.img-4.15.0-24-generic where it was detecting "bcma-pci" instead of "wl". to solve that problem I run a simple grub update so that my OS will be booting from the new initrd.img-4.15.0-38-generic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.