So I'm trying to install Ubuntu 16.04.5 on a Dell Precision 5820 with a GTX 1080 in it. These machines are lease refreshes. The previous machines we had Dell Precision 5810, did not exhibit any of these issues and worked out of the box.

I created a UEFI image of 16.04.5, selected "Install Ubuntu" and then starts throwing a bunch of error messages stating

[33.192238] nouveau 0000:05:00.0: DRM: base-0: timeout repeating over and over again. It never gets past this.

I tried the suggestions of adding "nomodeset" in grub when I'm booting. It progresses a little further but hangs at "failed to start Ubuntu Installation Service, please run journalctl to see what failed". I can't see what failed as I can't get a prompt since nothing is installed. I don't know where to go debug from here.

My computer boots to a black screen, what options do I have to fix it?

Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics

Ubuntu 16.04 Installation Issue Boots Into Black Screen or Freezes - Nouveau/Nvidia Driver issue 1080ti

Ubuntu 16.04 installation blank screen

Ubuntu 16.04 unable to boot with GTX 1080


However, I tried Ubuntu 16.04.1 LTS and did NOT have the issues with the video and was successfully able to install Ubuntu 16.04.1. Unfortunately, 16.04.1 didn't support the integrated Intel i219-LM network card. I tried 16.04.2, 16.04.3, 16.04.4 and they all exhibit the same behavior as 16.04.5 with the video.

Just as a test, I installed 16.04.1, installed broadcom NIC (which was successfully detected), and upgraded from 16.04.1 --> 16.04.5 with apt-get and had no video issues after reboot (I didn't install the video drivers), in addition, after it was upgraded to 16.04.5 the Intel 219-LM drivers were added and would work. I have a workaround, but it's REALLY annoying.

The kicker in this is that the Dell Precision 5810 worked 100% correctly. Put the USB boot drive in, select the drive in UEFI to boot and everything works out of the box.

How do I go about solving this?

  • 1
    I don't know any of the Dell models, but a brief search showed me that the model is a 2018 model. Of course, there is no reason I can think of why 16.04 wouldn't work...but I'm wondering if you tried 18.04? Perhaps it can cope with a newer model better than 16.04? Also, I wouldn't look at 16.04, 16.04.1, etc. You should use the latest one... Otherwise, you'll get it working but never upgrade? That sounds a like recipe for a disaster to me. – Ray Nov 1 '18 at 3:09
  • Oh...and I don't know the Nvidia cards well, too, but isn't the GTX 1080 post 2016? – Ray Nov 1 '18 at 3:10
  • @Ray correct, this is a brand new machine. The older generation Dell Precision 7910 workstation that this Dell 5820 is replacing works fine. Yes, that I would like to use the latest 16.04 release (which is 16.04.5) however I can't get it to boot. I simply tried 16.04.1 to see what would work (and it did), so it indicates to me that there is some type of regression. The GTX 1080 card is from 2016 and was also in the Dell 7910. The 16.04.4 boot media worked with 0 issues. We can't use 18.04 as the version of ROS we are using doesn't support it yet. – Kevin Vasko Nov 1 '18 at 3:23
  • Yes...I never understood Dell model numbers. Newer computers should have larger model numbers. :-) Anyway, my only suggestions would be random guesses. Like can you not use the Nvidia card and use the on-board video card instead. Perhaps disable the Nvidia card first. Once it boots and Ubuntu installs, then you can go to the Nvidia web site and download the latest drivers. I have an Nvidia card (not the 1080) and I actually use the drivers from the Nvidia site and not what's included in Ubuntu. – Ray Nov 1 '18 at 4:47
  • Indeed, it is surprising 16.04.1 works and the latter ones don't. You could install with 16.04.1 and then upgrade that to 16.04.5 . That's worth trying. Or...install 16.04.1, then install the Nvidia drivers from their web site, then upgrade to 16.04.5. Probably worth a shot as well. – Ray Nov 1 '18 at 4:49

So I do believe I figured out a "solution" but it literally makes zero sense and indicates a problem with the Dell BIOS and potentially some oversight in the Ubuntu installer.

Built 16.04.5 Desktop image with Rufus 3.3.1400.

Partition Scheme: MBR

Target system: BIOS (or UEFI-CSM)

All other options default.

1.0 So with the computer in UEFI Boot, Secure boot off.

Hit F12 to get into "One time boot menu".

In the "One time boot menu" you can select "Legacy" and UEFI boot options (e.g. USB Boot Device under legacy menu, and then under UEFI it shows the devices one being this Kingston USB device as a boot option).

1.1 In the UEFI Boot mode if you select the UEFI device, the system will not boot as describe above, no combination of nomodeset, acpi=off, noapci will work. The system hangs at a blinking cursor or in some type of error code as listed above.

1.2 In the UEFI boot mode if you select the USB boot drive under LEGACY, it boots into the selection screen correctly of (Install Ubuntu, Try Ubuntu, etc. menu). You will have to add the F6 options of nomodeset, acpi=off, noapci and then select the "Install Ubuntu" option and then the important part...YOU CANNOT BE USING ONE OF THE DISPLAY PORTS ON THE VIDEO CARD, YOU HAVE TO BE USING THE DVI PORT! At this point you will have the Desktop installer functioning.

I didn't really like this "solution" since you would have to be using the DVI port, so I dug some more...

2.0 I switched the machine into "LEGACY BOOT MODE, SECURE BOOT MODE OFF". In the one time boot option (when you hit F12 during POST) the boot menu will still show "LEGACY Boot Options" and "UEFI Boot Options". The same as before. However the results are different.

2.1 While in LEGACY boot mode in the one time boot option if you select the USB boot drive under LEGACY you get the SAME interaction as what I stated in 1.2. (e.g. to get the Installer Desktop GUI to show you have to add the nomodeset, acpi=off, noapci flags and then be plugged into the DVI port)

2.2 This is where it gets fun...while in LEGACY boot mode, select the USB boot device under the UEFI menu. The "Try Ubuntu, Install Ubuntu menu option shows", hit 'e' to edit the boot string, add the "nomodeset" flag hit F10, AND IT BOOTS CORRECTLY, with the DisplayPorts.

So why is this stupid? The computer has to be IN LEGACY BOOT MODE AND you must select the boot option from the UEFI menu. Which makes literally zero sense. Why would I need to put the computer in LEGACY mode to only select the boot option from the UEFI menu. You have to add the nomodeset option as well, but the options you have to select are quite absurd to me.

So for anyone running into this with BIOS 1.8 in a Dell Precision 5820.

  1. Create USB drive that will boot in UEFI mode. You can use Rufus that will boot in UEFI mode or Legacy mode, but I doubt this matters.

    1. Set the computer to LEGACY BOOT MODE (THIS IS IMPORTANT)

    2. When the computer is posting hit F12 to enter in the one time boot menu.

    3. Select the USB device to boot from WITHIN the UEFI menu (you will see both).

    4. Highlight the "Install Ubuntu" option and hit 'e'. On the "Linux" line before the "---" change the line to be "[...] nomodeset ---"

    5. Hit F10 to boot and you will get the Desktop installation menu.

Reading material:

https://access.redhat.com/solutions/58790 https://bugs.freedesktop.org/show_bug.cgi?id=105319

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.