0

I really like Ubuntu Studio and I enjoy the look, feel, and functionality along with the expanded capabilities of the the low latency kernel.

However I'm mostly a coder, and I like to have a lot of things open at once, and sometimes this can be really bad with a low latency kernel, so I decided to install the generic kernel to boot into when I'm not doing something like design or game development. I installed it like this:

sudo apt install linux-image-4.15.0-34-generic

I was able to but into it, however my 2k widescreen monitor isn't recognized in the settings when I boot to the generic kernel. How to I even begin to solve this problem without messing with the working low latency install?

UPDATE: it appears that all networking is down too.

UPDATE 2:

I was able to access more settings in nvidia x-server settings and the default display changed to my external monitor (the internal display was no longer recognized...) by installing 4.15.0-38 and the following packages:

linux-headers-4.15.0-38-generic
linux-modules-4.15.0-38-generic
linux-headers-4.15.0-38

I feel like this is the right direction, but what other packages will I need and is there a tool that makes this easier?

  • Mark those packages as automatically installed by sudo apt-mark auto '^linux-.*-4\.15\.0-38(-generic)?$' so that they can be automatically removed later. See Community Help Wiki for more information. – jarno Mar 15 at 8:09
0

Okay, I figured it out:

You should be able to install one package:

sudo apt install linux-generic

Reboot and select advanced options and select the generic kernel.

To make sure you're in the generic kernel once you verify everything is working:

uname -r

Should return X.X.X.X-generic where the X's are the (newest) kernel version number.

Also you might want it to boot into generic by default, in which case you would edit the grub configuration file:

sudo vim /etc/default/grub

(replace vim with your choice of text editor)

If it exists, replace the line that starts with GRUB_DEFAULT= with:

# Make the latest generic kernel the default
release=$(linux-version list | grep -e '-generic$' | sort -V | tail -n1)
GRUB_DEFAULT="Advanced options for Ubuntu>Ubuntu, with Linux $release"

Finally, run this command to update the grub configuration:

sudo update-grub
  • It is probably not desired the the old kernel is booted by default after installing new generic kernel. – jarno Mar 13 at 16:58
  • @jarno can you explain what you mean? "the old kernel" as in when an update occurs you'll need to update grub again? I don't know a workaround for that, so it would be nice if you have one to share. – David Kamer Mar 14 at 2:29
  • Grub will be updated automatically when you install a new kernel, but your fixed default item will remain, so it will not boot the latest generic kernel by default then. This can be worked around to use the latest generic kernel automatically, but it requires some work. Could you post a separate question about this problem? – jarno Mar 14 at 13:11
  • I edited your question a bit and try to edit the answer so that the latest generic kernel will be booted by default. – jarno Mar 15 at 8:42
  • 1
    I've approved the edit. – David Kamer Mar 15 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.