6

I have installed 18.04 Ubuntu Server. Then in terminal installed:

sudo apt-get install --no-install-recommends ubuntu-desktop

and when I now log into the desktop gui, my network shows as unmanaged at the top right, and in settings I do not get any wired settings options, why is this? enter image description here

I ran:

sudo lshw -c net

and had to take a picture of the results for the moment: enter image description here

6
  • 1
    Use the lshw -v command to dump your hardware info as text. Locate the section detailing your ethernet hardware. Edit your question to include the complete output of that section. We're looking for the manufacturer, exact model number, and whether or not a kernel module (driver) is active.
    – user535733
    Oct 31 '18 at 15:42
  • @user535733 Updated the question with the net information from lshw, but unfortunately I had to take a pic of it.
    – Jeffrey
    Oct 31 '18 at 15:56
  • Make sure it's plugged into the network, then run ip addr to see if it has an IP address. If so, then ping somebody. If it works, then reboot and see if it still works.
    – user535733
    Oct 31 '18 at 16:32
  • @user535733 I have tried all that, I can ping google.com fine.
    – Jeffrey
    Oct 31 '18 at 16:48
  • So it's JUST the missing Gnome Desktop setting? Everything else works?
    – user535733
    Oct 31 '18 at 17:11
17

I had this same issue which seems to be an Ubuntu NetworkManager bug. I was able to solve my problem by adding a missing config file and then restarting the NetworkManager as follows:

sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
sudo systemctl restart NetworkManager

This thread lead me to this solution, which I am posting here in case it helps you. Credit to skizo for finding something that worked.

0

Missing wired connections in settings:

Establish pppoe connection in Ubuntu: It's possible to bypass this problem using nmcli command. Create connection:

nmcli con edit type pppoe con-name "Connection name"

Set a username:

set pppoe.username <username>

Set a password:

set pppoe.password <password>

Save and quit:

save
quit

And this link is help you in details.

Not the answer you're looking for? Browse other questions tagged or ask your own question.