0

I tried to connect to one of the open VPN server in https://www.vpngate.net/ using openvpn as a client. So what I did:

  • download one of the ovpn files from one of the servers
  • execute:

    sudo openvpn vpngateconfig.ovpn

  • it last massage spouted:

    Initialization Sequence Completed

However, when I tried to ping any address across the web, it said

Temporary failure in name resolution

I tried to use different servers, but none of them worked. How to troubleshoot this? BTW, I'm using Ubuntu 18.10

regards

Edit:

~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=120 time=22.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=120 time=21.4 ms

~$ cat /etc/resolv.conf
# This file is managed by man:systemd-resolved(8). Do not edit.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs must not access this file directly, but only through the
# symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a different way,
# replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

nameserver 127.0.0.53

~$ ps auxc | grep -i dns
etherea+  5292  0.0  0.0 340736  2988 ?        Sl   15:11   0:03 gvfsd-dnssd
~$ ps auxc | grep -i resolv
systemd+   735  0.0  0.0  55932  4000 ?        Ss   14:43   0:04 systemd-resolve

This happened when either VPN was up or down.

  • Does ping 8.8.8.8 work when the VPN is up? Edit your question and show me the output of cat /etc/resolv.conf and ps auxc | grep -i dns and ps auxc | grep -i resolv. Report back to @heynnema – heynnema Oct 31 '18 at 13:50
  • ps: show me the cat /etc/resolv.conf when the VPN is up. – heynnema Oct 31 '18 at 13:56
  • @heynnema I just added additional output that you requested – ethereal1m Oct 31 '18 at 14:31
  • 1
    vpngate doesn't appear to support linux, and their .ovpn files are not updating your /etc/resolv.conf file, hence your dns requests are failing. Contact vpngate and ask them for the ddns name of their dns server for the particular vpn server that you're connecting to, and that can be edited into /etc/resolvconf/resolv.conf.d/ files so that /etc/resolv.conf will get properly updated. – heynnema Oct 31 '18 at 14:36
  • they list ddns hosts name for all the server there. My /etc/resolvconf/ doesn't have resolv.conf.d directory. Should I create one and its file? What is the name of the file? – ethereal1m Oct 31 '18 at 14:46
2

I found a nice GUI client that does all the work, from listing available VPNgate servers, to connect to one of the:

Gvpngate

| improve this answer | |
  • this is gold, good find – mikakun Jan 11 at 11:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.