I have an old Photosmart C4500 and I want to print a page from Firefox on Ubuntu16.04. Yet the printer is stuck at processing status. I can still cancel the task but and relaunch it but it remains stuck. I also removed and reinstalled the printer but it doesn't changed anything. It doesn't seems the printer actually receive data.

enter image description here

Do you have any idea on how to make this work ?

I clicked on additional printer settings and was either able to add a new printer enter image description here

Or to troubleshoot but it told me that "there is no obvious solution to your problem". Furthermore I wasn't able to log its report as far as it doesn't accept my password.

mike@mike-thinks:~$ su -c 'journalctl -u cups.service --since="None" --until="2018-11-04 10:19:41"' > troubleshoot-logs.txt
su: Authentication failure
  • Try clearing the queue and printing a test page. If that isn't working, it may be that the printer address is wrong (maybe it changed) or the printer is offline for some reason. Admittedly, "Processing" isn't a very helpful message for this case... Nov 18, 2019 at 21:04

6 Answers 6


I was having a combination of issues, including this one:

  • using the system settings to manage printers gets my jobs stuck at processing. <--- OP's main issue
  • wanting to install an HPLIP printer, and not CUPS managed/driverless stuff? <--- also OP's issue
  • needing to install the printer from additional printer settings but getting stuck at auth (maybe someone else is lucky enough not to need to do this)
  • getting stuck at auth because the additional printer settings does not maintain that I am an admin user when opening it, so needing to disable authentication. (ideally we figure out how to run these additional settings as an admin - but until then... use my [probably vulnerable] solution.)

So taking others' advice, I tried to install the printer from the additional printer settings, but ran into authentication issues, where every time I tried to install a printer under those settings, I was prompted for user/pass.

Not my solution, but maybe yours

I saw other answers where people were being prompted for this, and their solution was to:

  1. Pause the cups server. Open the terminal and type sudo service cups stop
  2. Edit the /etc/cups/printers.conf file, commenting out (by prepending a # to) the line that has AuthRequired username,password. This line did not exist for me, so it was extra confusing because I don't know what the username/password is that I keep getting prompted for. Maybe you have this issue and that's why I will leave this answer.
  3. Start the cups server back up sudo service cups start

My solution

So I found another answer that helped me remove the admin user as a requirement to adding/removing printers.

This is kind of dumb and annoying, because the "additional printer settings" does not continue to run as an admin and it doesn't seem to recognize what user I am, so that's the whole reason this is necessary. I cannot find a way to run these additional settings as an admin user, so this solution is best for now. (note that I am in individual and not going to use this on a network other than my home).

  1. Pause cups server (same as above) sudo service cups stop
  2. edit the /etc/cups/cupsd.conf and look for <Policy default> and underneath that, comment out the lines AuthType ... and Require user... for any area you do not want to require auth. (Commenting out means prepending the line with a #)
  3. start the cups server again. (same as above) sudo service cups start
  4. install the printer from the additional settings area
  5. print test page
  6. profit.

Mine looks like this:

# All administration operations require an administrator to authenticate...
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
#AuthType Default
#Require user @SYSTEM
Order deny,allow

# All printer operations require a printer operator to authenticate...
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deac$
#AuthType Default
#Require user @SYSTEM
Order deny,allow


None of the other solutions here worked for me. I ran into a problem where as soon as I would check the "enabled" field on the printer, it would try fail to print from the queue, and then it would automatically uncheck the field. Here's what I had to do.

I also have an HP printer, an OfficeJet 6500.

I went to https://123.hp.com/us/en/ and followed a series of links for configuring the printer on Linux. I knew to go to this initial URL because I manually printed out the "Wireless Quick Start Guide" using the touch screen and buttons directly on my printer.

It led me to install this: https://sourceforge.net/projects/hplip/

I followed the instructions, and when I was done all of the queued jobs on my printer said "Stopped". I found a forum post online that said to try removing the printer, and then adding it again, which I did. I had to go through a screen where it asked me what driver I wanted, and the default "recommended" option was a generic driver with ASCII coding. I selected the model of my printer instead.

I queued up the job again, and it worked!

  • The only correct solution for me. This is I suspect the best one because other solutions may be obviated by the simple reinstallation process. Dec 15, 2022 at 22:36

Click the button on the bottom right saying "Advanced Printer Settings". The old GUI will appear. If you install the printer from this GUI, it might solve the problem.

  • 1
    Actually it is additional printer settings but didn't managed to solve the problem from there. Nov 4, 2018 at 9:24

None of the other answers worked for me.

I solved the issue by manually inserting the printer IP address like in this answer: how-do-i-modify-a-printers-ip-address-in-cups#913534

Somehow CUPS wasn't able to handle the url anymore, although it was still capable of correctly identifying the printer.

Hope it helps (it took days for me to figure it out!)


Actually just restarting cups worked for me

sudo service cups restart

Another answer:

I recently switched routers. My subned was originally, and the printer pulled a lease there. The new router is The printer refused to give up its old lease.

The "add a printer" dialog would still see the printer - I suspect the broadcast ping was getting through, but the jobs would stick in processing. All genuine printer traffic was dropped by the router. Force renewing the lease on the printer (turned ip to manual, and then back to dhcp) allowed it to work.

I could tell it was better, because I could see the ink level of the printer in CUPS. Printing then worked as expected.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .