1

I have a new fresh Kubuntu installation. I have used Linux Mint and Ubuntu before, those OS have GUI settings for input method, where I can choose ibus or fcitx and type Vietnamese (my language, we use ibus-teni to type Vietnamese https://github.com/teni-ime/ibus-teni ).

Ubuntu Input method setting

I did install ibus-teni, I can run ibus from Search tool, but couldn't type Vietnamese. So how do I setup the input method from default to ibus? Why does not Kubuntu have GUI settings for it like Ubuntu?

0

I think there is an Input Method Configuration GUI tool on Kubuntu, from where you can set IBus.

If you don't find it, you can also do it from command line:

im-config -n ibus
  • Unfortunately after running that line and launch ibus manually (yeah, I have to go to KDE launcher and search for "ibus" and run it), I still can not type Vietnamese. – Feliks Nov 1 '18 at 9:41
  • Oops! After a restart, now I can type Vietnamese! But there is no icon of ibus showing which keyboard I'm using. – Feliks Nov 1 '18 at 12:45
  • @Feliks: Hopefully some Kubuntu user can give you a hand about the icon. – Gunnar Hjalmarsson Nov 1 '18 at 13:20
0

This happens when the ibus-daemon does not start automatically after booting into Kubuntu. Do the following steps to rectify this.


Type 'Autostart' in Application Launcher search bar.

This will open the 'Autostart System Settings' dialogue.

Now click 'Add program' button.

Click 'Open file' button next to the search bar.

Go to Root -> usr -> bin directory.

Type 'ibus-daemon' in the 'Name' textbox.

Out of the three options appearing in the list, select 'ibus-daemon' and click 'Open' button.

Now you should be back in 'Autostart System Settings' dialogue with 'ibus-daemon' selected under Desktop File category.

Select the 'ibus'daemon' and click 'Properties' button.

In the properties dialogue open 'Applications' tab.

Type 'iBus Daemon' in the Name textbox and type '/usr/bin/ibus-daemon start' in the Command textbox.

Now click 'OK' to come back to Autostart System Settings and click 'OK' here too.

REBOOT YOUR MACHINE. (VERY IMPORTANT)


Your iBus daemon shall now start automatically and you shall see the 'EN' icon in the panel where you can click and select the language of your choice.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.