0

When trying to launch steam, I get

Steam needs to install these additional packages: 
    libgl1-mesa-dri:i386, libgl1-mesa-glx:i386

Then it tries to install the packages and gives me

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
3
  • There are tons of Steam Solved Questions on Here...Did you search thru some or just need a quick fix? Oct 31, 2018 at 1:42
  • I did look through them and it seems that there used to be a command that would work back then few years ago. In fact it was this one sudo apt-get install libc6:i386 libgl1-mesa-dri-lts-utopic:i386 libgl1-mesa-glx-lts-utopic:i386 But when i try to run the command, it gives me this E: Unable to locate package libgl1-mesa-dri-lts-utopic:i386 E: Unable to locate package libgl1-mesa-glx-lts-utopic:i386
    – user874212
    Oct 31, 2018 at 1:46
  • This is actually in the Ubuntu Store as a Snap. Doesn't work there either? Oct 31, 2018 at 10:21

2 Answers 2

0

I got steam working after installing the newest AMDGPU drivers https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

0

Install it through the steam website and choose to open it with software installer. Works just fine. Reinstalling if you already have it installed. I did this on a fresh install.

2
  • Can you please expand a little bit? "Fresh installs" are generally free of issues. If it isn't a bug it won't affect new installations and as a result you might not be able to reproduce the problem on your system.
    – Kulfy
    Jun 26, 2019 at 16:06
  • Sorry. Like it says, I’m new. After doing a fresh install on hyper visor, I was unable to install steam via the software installer. It gave back errors, similar to the ones described above. But then once I went to the steam website and chose to install it there, it worked perfectly. I noted that the symbol was different than the original symbol in the software installer. Or store, or whatever it’s called. Maybe the version that’s already there is unsupported? I’m unsure, but doing it through the website worked fine for me.
    – CurtisN
    Jun 27, 2019 at 17:21