0

I have a T450s and run Ubuntu 18.04.1 LTS. I had problems with my wifi card Intel 7265 and nothing helped. So I deleted all "iwl..." files from /lib/firmware and put new drivers in there "iwlwifi-7265-14.ucode" and "iwlwifi-7265D-14.ucode".

Now my system does not detect any wifi adapter at all. I googled a lot, but nothing seems to help.

Here are some logs:

    dominik@dominik-ThinkPad-T450s:~$ nmcli radio wifi
    enabled

running ifconfig

:~$ ifconfig
enp0s25: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.30.8.243  netmask 255.255.0.0  broadcast 10.30.255.255
        inet6 fe80::b079:19e0:d069:43df  prefixlen 64  scopeid 0x20<link>
        ether 50:7b:9d:61:f5:6c  txqueuelen 1000  (Ethernet)
        RX packets 8333  bytes 4221893 (4.2 MB)
        RX errors 0  dropped 13  overruns 0  frame 0
        TX packets 3638  bytes 518426 (518.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf1200000-f1220000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 982  bytes 134055 (134.0 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 982  bytes 134055 (134.0 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

running iwconfig

    dominik@dominik-ThinkPad-T450s:~$ iwconfig
enp0s25   no wireless extensions.

lo        no wireless extensions.

Does anyone have an idea? Thank so so much!

3
  • 1
    Deleting firmware files was a wrong move. Not sure what you've expected. – mikewhatever Oct 30 '18 at 16:04
  • Definitively, I expected to be able to replace firmware drivers. With „sudo rm iwlwifi-*“ I expected all drivers regarding the WiFi adapter to be removed. Afterwards I put the correct drivers back into the folder ... – Domi5432 Oct 30 '18 at 16:52
  • 1
    Please edit your question to show the result of the terminal command: sudo modprobe iwlwifi && dmesg | grep iwl Welcome to Ask Ubuntu. – chili555 Oct 30 '18 at 19:50
0

Ok I downloaded iwlwifi-7265D-29.ucode and put it into /lib/firmware ... now I see WiFi networks again but it seems to be very unstable ... with my mobile I have a good connection to the WiFi which my laptop doesn’t even see. Basically my WiFi doesn’t work at all even if the computer sees the adapter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.