5
(appstreamcli:13767): GLib-CRITICAL **: 08:57:18.126: g_variant_builder_end: assertion '!GVSB(builder)->uniform_item_types || GVSB(builder)->prev_item_type != NULL || g_variant_type_is_definite (GVSB(builder)->type)' failed

(appstreamcli:13767): GLib-CRITICAL **: 08:57:18.126: g_variant_new_variant: assertion 'value != NULL' failed

(appstreamcli:13767): GLib-ERROR **: 08:57:18.126: g_variant_new_parsed: 11-13:invalid GVariant format string
Trace/breakpoint trap (core dumped)
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code
4

Following works for me:

apt-get install --reinstall libappstream4

Check this thread for details: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=906538

1
  • naah. still same – lone_coder Jan 10 at 18:19
0

I had the same problem in debian buster and found this to work: this

  1. Purge appstream and gnome packages (to be safe, make a list of packages to re-install latter on):

    # apt-get remove --purge appstream gnome*
    

You can use the command tasksel --list-tasks to see available desktop options to install.

4
  • 1
    are you sure to run apt-get remove --purge gnome*? that's will remove all gnome packages which to handle Ubuntu Packages Graphical and your link reference is not yet get response another users, is it an good answer or an bad answer!!! – abu-ahmed al-khatiri Nov 28 '18 at 15:43
  • That's what I did, remove all gnome packages and reinstalled the task-gnome-desktop, that will reinstall the desktop environment back. That fixed the problem. – user1694490 Nov 28 '18 at 17:46
  • I had the same error (while installing a php package) , but I did not have to remove/reinstall gnome to get it solved. – hornetbzz Dec 22 '18 at 23:08
  • Would be nice if you publish your solution. Windows like solutions like reinstall things are not good solutions for sure. – user1694490 Dec 26 '18 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.