0

I am facing the following issue :
Ubuntu 18.04 Screen flickering on a 4K laptop and the only workaround I have found is to never let my screen fade to black!

However, when I lock my screen, even on power, the screen turns black soon (though the computer has not been suspended). How can I avoid this?

In short, I want the lock screen display to persist and not fade away [to turn off screen].

3
  • I'm not sure this applies to 18.04 (it only says 18.10, but it should be the same), so I won't post it as an answer, but perhaps you could try it and answer it yourself if it works? These are instructions for disabling 'screen blanking' help.ubuntu.com/stable/ubuntu-help/display-blank.html.en
    – Tobias
    Oct 29, 2018 at 20:19
  • @Tobias screen still blanks when computer is locked. I want to prevent this.
    – midi
    Oct 29, 2018 at 20:38
  • If it doesn't apply to the lock screen, then I don't think this is possible. See this question: askubuntu.com/questions/612663/… - there is a workaround there. I tried to flag this as a duplicate of that question, but it doesn't show up in the search box.
    – Tobias
    Oct 30, 2018 at 10:58

1 Answer 1

0

This behaviour is currently not possible with a default GNOME installation, see this bug report for details: https://bugzilla.gnome.org/show_bug.cgi?id=773645

As a workaround someone (sun_wang is his username) created this extention that you can use: https://extensions.gnome.org/extension/1414/unblank/

Make sure that the version you choose is compatible with the version of GNOME you are running. To check which version is running, 'Activities' and press 'About'. For more information, see here: https://help.gnome.org/users/gnome-help/stable/gnome-version.html.en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.