1

After migrating from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS I faced this old and annoying Xorg bug. It's impossible to use Ctrl+Shift hotkeys in Unity if Ctrl+Shift is configured to change keyboard layout. This issue is also mentioned here.

A bugfix ported from ArchLinux is proposed:

sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt update
sudo apt dist-upgrade

but it doesn't work for Unity.

Ubuntu 18.04 is shipped with Xorg 1.19.6 while Ubuntu 16.04 - with Xorg 1.18.4 (and hotkeys were working with it in Unity). My hope was to find 1.18.4 version for bionic in xorg-edgers but seems it's only available for xenial.

My question: how can I downgrade Xorg to 1.18.4 on Ubuntu 18.4? Should I start to dig into sources to build it manually or is there an easiest way?

1

I'm sorry but even as being an author of this PPA I do not have a solution.
Downgrading Xorg and patching it may end with difficult long deep dependency resolution. I tried to install Xenial HWE packages from my PPA on Bionic with no luck.
So there is something wrong inside Unity or GNOME sHell.

You can read my complete opinion on Ubuntu Community (first and second). I cite latter here:

The universal remediation to fix current bug - do not use both GNOME sHell and beloved Unity

and purge them with commands below:

sudo apt-get purge gnome-shell ubuntu-gnome-desktop \
ubuntu-desktop ubuntu-unity-desktop unity-session

sudo apt-get autoremove

but use Cinnamon, KDE, MATE (my favorite) or Xfce instead with packages from my PPA:

#Choose your favorite desktop 
#sudo apt-get install cinnamon-desktop
#sudo apt-get install kubuntu-desktop 
sudo apt-get install ubuntu-mate-desktop^
#sudo apt-get instal xubuntu-desktop 

#Add my PPA
sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
sudo apt-get update
sudo apt-get dist-upgrade

#Reboot and enjoy
sudo reboot

Optionally pin (lock/hold) related packages to prevent their upgrade with:

cat <<EOF | sudo tee /etc/apt/preferences.d/pin-xorg-hotkeys
Package: *
Pin: release o=LP-PPA-nrbrtx-xorg-hotkeys
Pin-Priority: 1337
EOF

If you are not satisfied with obtained results - write a letter to Mark Shuttleworth / Xorg / GNOME / all bug-trackers / all IRCs / all LoCos / all treads of Ubuntu-Forums / Bill Gates about your problem and then execute:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:nrbrtx/xorg-hotkeys
sudo rm /etc/apt/preferences.d/pin-xorg-hotkeys

If you would like to complete with installation of MATE DE you can use Mutiny panel layout to avoid some headache :)

Mutiny on Ubuntu MATE 18.04 LTS

The last option - you can try to write PM to the user, suggested to downgrade Xorg to give you complete working instruction.

1
  • Thanks a lot for all your efforts, I've seen those community thread and read all your messages there. Using another DE is a way to go but I love Unity very much and prefer to stay with it. Seems that I found a partial workaround for GNOME but not for Unity yet... – ezze Oct 30 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.