1

I have a Windows 10 laptop (Lenovo Z570) and I decided to give Ubuntu a try and install it alongside Windows. So I shrank my D: partition using Windows disk management utility, downloaded the Ubuntu ISO image and booted it from USB. During the setup I chose the Something else option (Note: Ubuntu didn't detect Windows and didn't offer me the option to install it alongside Windows so I chose the Something else option) and made 3 partitions for root, swap and home. When I proceeded with the installation process, an error appeared saying

The 'grub-efi-amd64-signed package failed to install into an target. without the GRUB boot loader, the installed system will not boot.

So I ran the setup again and this time I chose to overwrite the existing Ubuntu installation that wasn't completed and this time the setup succeeded. But when I restarted my laptop, I found out my laptop booted directly into Ubuntu instead of showing me the bootloader. Just when I turn on my laptop and before Ubuntu logo appears, I encounter this error (this error got fixed but GRUB still can't detect Windows 10)

System BootOrder not found. Initializing defaults.

Things I have tried:

  • Running sudo update-grub and restarting
  • Running boot-repair and restarting and repeating that again (Here's the pastebin for the first time: http://paste.ubuntu.com/p/mnb2t6NYmz/ and the second: http://paste.ubuntu.com/p/2j2H8JvzYh/
  • Changing the boot order to give Ubuntu the priority
  • Mounting the Windows partition, then running sudo os-prober then sudo update-grub
  • Opening GRUB manually by pressing Esc in BIOS, but i just see Ubuntu listed and Windows isn't there

One thing I noticed when changing the boot order is that there were two values called ubuntu not one. Maybe this has to do with the first failed setup I did and then when I did a second setup so maybe it got a little messed up? (This also got fixed and instead it's a single value)

0

1 Answer 1

4

Give this a shot:

On a terminal type sudo update-grub. You should see something like: "windows detected". Restart, and hopefully when Ubuntu boots, you will see a menu to choose in which OS you want to boot.

If this doesn't work check out boot-repair.

Hope it helped

4
  • Okay so I tried 'sudo update-grub' but it didn't work. I tried the boot-repair tool and it's been going all good until I stumbled upon a warning message "FlexNet detected. Please backup your data before this operation. Do you want to continue? The tool prompted me to choose to install GRUB in my main hard drive or the boot partition. I installed it in the boot partition but this warning message made me anxious that there's a probability I lose all my data. What is this warning message about and what exactly is FlexNet? Oct 29, 2018 at 22:55
  • Now I proceeded with boot-repair. But nothing changed so far. Still boots straight to Ubuntu and doesn't show me grub. Any suggestions? Oct 30, 2018 at 12:58
  • I really don’t know my friend, you should try emailing boot.repair@gmail.com. They’re probably gonna take a couple of days to reply and you need to provide them with some .log files. Sorry for not being helpful enough. Oct 31, 2018 at 0:09
  • It's all cool! Thanks for trying, really appreciate it! :) Oct 31, 2018 at 17:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.