0

I've seen old posts mentioning a Rhythmbox visualization plugin. But it doesn't seem like it has it anymore. Is there a way to get it back?

0

According to the search on http://packages.ubuntu.com this package was available in 17.10. Installing software from old release is usual bad idea, but if you really to install it then, you can execute the commands below to download packages from 17.10 and install them into system.

mkdir ~/Downloads/rb
cd ~/Downloads/rb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox/gir1.2-rb-3.0_3.4.1-2ubuntu5_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox/librhythmbox-core10_3.4.1-2ubuntu5_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox/rhythmbox-data_3.4.1-2ubuntu5_all.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox/rhythmbox_3.4.1-2ubuntu5_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/universe/r/rhythmbox/rhythmbox-plugin-visualizer_3.4.1-2ubuntu5_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox/rhythmbox-plugins_3.4.1-2ubuntu5_amd64.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/r/rhythmbox-plugin-alternative-toolbar/rhythmbox-plugin-alternative-toolbar_0.17.5-1_all.deb
sudo apt-get install ./*deb

I have never used it, but you can try. If it works as expected then you can pin these manually installed packages by long single command below to prevent their upgrade:

cat <<EOF | sudo tee /etc/apt/preferences.d/pin-rb
Package: gir1.2-rb-3.0
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

Package: librhythmbox-core10
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

Package: rhythmbox
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

Package: rhythmbox-data
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

Package: rhythmbox-plugin-alternative-toolbar
Pin: version 0.17.5-1
Pin-Priority: 1337

Package: rhythmbox-plugins
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

Package: rhythmbox-plugin-visualizer
Pin: version 3.4.1-2ubuntu5
Pin-Priority: 1337

EOF

For your information - modern FlatPak version does not include visualized plug-in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.