4

On 18.10, I'm still seeing the zombie ttf-mscorefonts-installer “Failure to download extra data files” dialog every time I restart my computer.

This is a vintage bug that has been causing woe for Ubuntu users since at least 2012. I am aware of other questions and answers about this issue, but none of the solutions have worked in this case. For reference, notable prior questions are:

Previous solutions include:

Deleting partially downloaded files

sudo rm -rf /var/lib/update-notifier/package-data-downloads/partial/

This directory does not exist on my system. There are no partially downloaded files to delete.

Sometimes an empty file is created when the failure dialog appears at:

/var/lib/update-notifier/package-data-downloads/ttf-mscorefonts-installer.failed

It does not make any difference if I delete this file or rename it to ttf-mscorefonts-installer as answers to other previous questions have suggested.

Installing a newer version from a Debian package

In the past, it was version 3.4 causing problems and users could download and install version 3.6 from a Debian repository like so:

cd /tmp
wget http://ftp.de.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.6_all.deb
sudo dpkg -i /tmp/ttf-mscorefonts-installer_3.6_all.deb
# Also sometimes suggested:
sudo dpkg-reconfigure ttf-mscorefonts-installer

Later a Debian package for 3.7 became available and this method apparently worked for some users using 3.7.

The latest version available in the repositories seems to be the curiously-named 3.7ubuntu4~really3.6ubuntu3. Which appears to be “newer” than the Debian 3.7 package from the system's point of view.

I have tried installing both the system version and the 3.7 Debian package, purging previous installations beforehand, and the failure dialog still appears.

Download fonts manually

Some answers offer links to the font files contained in the package and suggest downloading them manually to the target directory. In my case, the fonts are all already there in /usr/share/fonts/truetype/msttcorefonts/. Downloading and replacing them from other sources doesn't help, the dialog still appears.

I have tried all combinations of previous solutions in all the orders I can think of and nothing solves the problem.

What else can I try to prevent this insistent dialog from appearing?

2

Manually download the Debian v3.7 package, purge the Ubuntu version and then install the Debian package. That'll successfully download all the files.

wget http://ftp.uk.debian.org/debian/pool/contrib/m/msttcorefonts/ttf-mscorefonts-installer_3.7_all.deb

sudo apt-get purge ttf-mscorefonts-installer

sudo dpkg -i ttf-mscorefonts-installer_3.7_all.deb
  • Thanks for this, on Ubuntu 19.04 this was driving me mad on each boot. Works like a charm. – NaughtySquid May 8 at 8:37
1

There is another bug report on Canonical's website you can try:

In this report there were two issues:

  • EULA (End User License Agreement) not accepted by pressing Tab followed by Enter
  • Left over symbolic links needed to be manually removed:
sudo rm /etc/alternatives/nvidia_settings_conf
sudo rm /etc/alternatives/x86_64-linux-gnu_gl_conf
sudo rm /etc/ld.so.conf.d/nvidia_settings.conf
sudo rm /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.