0

I have a Dell gamer model 7567, and I was using the 16.04 LTS version of Ubuntu and recently saw the need to format it. I have already installed the latest LTS version, (18.04) but I'm having trouble setting the keyboard to work with a Brazilian layout.

I found a solution that solves my problem but every time I reboot the system it returns to the previous standard.

This is the command that I am using every time I reboot the system:

setxkbmap -model abnt -layout us -variant intl

Would I have some way to leave this script set up so I do not have to run it every time I turn on the notebook?

2
  • Is the keyboard a US English layout, which you use as if it were a Brasilian Portuguese layout (e.g. you know what to type even though the characters printed on the keys do not match up)? If yes, you can try this as a cronjob: @reboot setxkbmap -model abnt -layout us -variant intl. This is a crude workaround though, and I suspect there is a better way. Can you also try sudo dpkg-reconfigure keyboard-configuration, set it to the desired language, and reboot to test? – Tom Brossman Oct 28 '18 at 18:16
  • 3
    Possible duplicate of How to permanently configure keyboard – Tom Brossman Oct 28 '18 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.