2

I have a Brother DCP 7065DN printer connected by USB which stopped working after upgrading to Ubuntu 18.10.

Tried a variety of ways to fix the issue including Command line reinstall of driver

apt-get purge cups

apt-get install cups

dpkg -i --force-all dcp7065dnlpr-2.1.0-1.i386.deb

dpkg -i --force-all cupswrapperDCP7065DN-2.0.4-2.i386.deb

dpkg -l | grep Brother

Everything looks fine on the output:

ii brscan-skey 0.2.4-1 amd64 Brother Linux scanner S-KEY tool

ii brscan4 0.4.6-1 amd64 Brother Scanner Driver

ii cupswrapperdcp7065dn:i386 2.0.4-2 i386 Brother DCP7065DN CUPS wrapper driver

ii dcp7065dnlpr:i386 2.1.0-1 i386 Brother DCP-7065DN LPR driver

ii printer-driver-brlaser 4-1 amd64 printer driver for (some) Brother laser printers

ii printer-driver-ptouch 1.4.2-3 amd64 printer driver Brother P-touch label printers

When I print a test page it looks like it works, print says receiving but nothing prints. Same from a text editor.

Go to http://localhost:631/printers/Brother_DCP-7065DN - printed test page and same thing - looks to work but nothing prints.

If I manually remove/add the printer from the Ubuntu Device / Printers I get a different error message: stopped "Filter failed".

Also tried the RPM installer package, generic lpr and generic cups drivers from the Brother driver site but didn't work either.

Help!

Wull

0

2 Answers 2

1

Fixed issue with following commands:

sudo rmdir /usr/share/ghostscript/9.25/iccprofiles

sudo apt-get install --reinstall libgs9-common

Wull

1

I tried the solution recommended above (reinstalling the libgs9-common library). It turned out I already have version 9.26 and the reinstall just put back the same version. In any case, it didn't help. The problem persists. I was able to confirm, however, that the problem is not in Libre Office: I downloaded a landscape document from another source (WPI_SampleLandscape.pdf) and the same behavior remained. The only workaround I could find was to rotate my landscape document to portrait orientation before printing it.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .