1

My mullvad VPN was working, then I upgraded to 18.10. Now when I use their UI client, it connects fine, but DNS is not working. I can ping google.com by IP but not by google.com.

I can resolve it by specifying the interface:

>resolvectl query google.com
google.com: resolve call failed: All attempts to contact name servers or networks failed

>resolvectl -i tun0 query google.com
google.com: 216.58.212.174

-- Information acquired via protocol DNS in 1.1ms.
-- Data is authenticated: no

The man page for resolvectl says this about the -i option:

Note that this option has no effect if system-wide DNS configuration (as configured in /etc/resolv.conf or /etc/systemd/resolve.conf) in place of per-link configuration is used

So is my system using per-link configuration? How do I check that?

Other info:

>ls -ld /etc/resolv.conf
lrwxrwxrwx 1 root root 29 Oct 28 10:10 /etc/resolv.conf -> ../run/resolvconf/resolv.conf

>cat /run/resolvconf/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.53

Further info as requested:

It is using openvpn 2.4.6-1ubuntu2

Output from systemd-resolve --status (when the vpn is connected):

Global
       LLMNR setting: no
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
          DNSSEC NTA: 10.in-addr.arpa
                      16.172.in-addr.arpa
                      168.192.in-addr.arpa
                      17.172.in-addr.arpa
                      18.172.in-addr.arpa
                      19.172.in-addr.arpa
                      20.172.in-addr.arpa
                      21.172.in-addr.arpa
                      22.172.in-addr.arpa
                      23.172.in-addr.arpa
                      24.172.in-addr.arpa
                      25.172.in-addr.arpa
                      26.172.in-addr.arpa
                      27.172.in-addr.arpa
                      28.172.in-addr.arpa
                      29.172.in-addr.arpa
                      30.172.in-addr.arpa
                      31.172.in-addr.arpa
                      corp
                      d.f.ip6.arpa
                      home
                      internal
                      intranet
                      lan
                      local
                      private
                      test

Link 6 (tun0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
  Current DNS Server: 10.9.0.1
         DNS Servers: 10.9.0.1

Link 3 (wlp1s0)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
  Current DNS Server: 192.168.0.1
         DNS Servers: 192.168.0.1
          DNS Domain: ~.

Link 2 (eno1)
      Current Scopes: DNS
       LLMNR setting: yes
MulticastDNS setting: no
  DNSOverTLS setting: no
      DNSSEC setting: no
    DNSSEC supported: no
  Current DNS Server: 192.168.0.1
         DNS Servers: 192.168.0.1
          DNS Domain: ~.


ps auxc | grep dns returns nothing
>ps auxc | grep resolv returns:
systemd+   557  0.0  0.1  55480  9236 ?        Ss   Oct28   0:06 systemd-resolve
3
  • whats the output of systemd-resolve --status? What does mullvad VPN use - is it OpenVPN? I think i might be having a similar problem. – Maciej Lecki Oct 30 '18 at 23:48
  • 1
    Edit your question to include the output of ps auxc | grep -i dns and ps auxc | grep -i resolv. Report back to @heynnema – heynnema Oct 31 '18 at 14:32
  • Same problem here.. – arnuschky Jun 20 '19 at 20:54
0

I emailed mullvad support and they suggested that I just use openvpn, i.e. same response as Coffee_Mug in: Mullvad vpn won't connect on ubuntu 18.04

On one computer, I used the old mulvad client via "env MULLVAD_USE_GTK3=yes mullvad", but on the other I got the same error as amicose in Mullvad VPN Client won't start on 18.04

For that second computer, I gave up trying to figure out why it wouldn't work and just set up openvpn to connect to one server.

0

Version 2018.6 of the Mullvad app works fine

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.