1

This question already has an answer here:

I have a Ubuntu 18.04 partition on my HP laptop (originally Windows 10). I am only able to connect to Wi-Fi while I am in the same room of the modem. When I go to another room I get the message "no networks available", even if other devices can connect and the "Windows part" too. I searched for problems like this, but I couldn't get a solution. I hope you can help me, thank you.

I tried lspci -knn | grep Net -A3; rfkill list
This was the output:

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter [10ec:b723]
    Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter [103c:804c]
    Kernel driver in use: rtl8723be
    Kernel modules: rtl8723be
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
5: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

I tried uname -r, I got 4.15.0-36-generic.

marked as duplicate by pomsky, karel, chili555 networking Oct 29 '18 at 13:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.