When I enter my password in the log in screen the screen goes black for a second or two, then returns me to the login screen. No matter how many times I try, I haven't been able to login. I never had this problem before.

pressing ctrl+alt+F1 works and I can login and run commands.

Searching online I found others have reported similar problems, but none of the reported solutions have worked for me. These include running clean, autoclean, and autoremove. .Xauthority is owned by me and not root.

Any ideas that may help me solve, or at least diagnose the problem?

Edit 1: I ran the command df it returned this:

enter image description here

Edit 2: Actions I performed days before the problem began, that might be part of the problem: I tried installing matlab and during that process my root partition "/" filled up. Then I deleted some old kernels to free up some space, keeping only the last 2.

Edit 3: Running sudo find / -size "+200M" gives the following output: enter image description here

up vote 1 down vote accepted

You have a full root partition /dev/sda6 (Unavailable 0, Used% 100%).

  1. Try free some space

    • Reboot to recovery mode, select clean from the menu.
    • Or quick try delete packages archive, sudo rm /var/cache/apt/archives/*.deb, check df again.
    • If still didn't get free space, look for large files using find command. Example:

      sudo find / -size "+200M"
      

      "+200M" means larger than 200 MiB

      And delete what seems not important or could be restored later.

  2. Reboot

Note: about the root partition size, based on personal experience.

  • 14GB seems small but it is okey for someone using machine only for Internet communications and Office things. Going beyond that probably you going to need more. My usual minimum is 20~25GB. If I'm expecting to install an engineering (1~12GB at least for electronics) or game software which nowadays raised the bar (some even passed 25GB), I go higher 30~65GB (40~10% of HDD capacity).

  • Advise, don't ignore low space warning message. Most applications are not robust enough to deal "no space left" then you may face side-effect issues that are sometimes hard to troubleshoot, like corrupted file, incomplete installation,... Which may appear to you just an app is unable to load, login loop or weird behavior because underlying service couldn't start...

  • I select clean from the menu in recovery mode. I still tried deleting the .deb packages but there were none to delete, which I assume means that the "clean" process did its job. Then df returns that / partition is still full. Rebooted twice just to check and I was still not able to login. – user87317 Oct 28 at 16:15
  • I cannot attach an image of the output here as a comment so I added it to the original post. – user87317 Oct 28 at 20:14
  • Removing CDFPlayer brought saturation of the root directory down to 74%, which allowed me to login. However, I wonder if 74% is still too high for a root partition with about 14GB. Is this reasonable? Should I suspect a larger underlying problem, or should I simply increase the partition size? – user87317 Oct 28 at 23:35
  • @user87317, not a problem but watch it is goes below 5~10%. You have around 25% free which is ~3.5GB which may get filled with just one big application. I added a note about size to the question. – user.dz Oct 29 at 6:54
  • Let us continue this discussion in chat. – user.dz Oct 29 at 7:05

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.