3

I spent some time this morning trying to designate an ext4 partition as my Dropbox sync location, but Dropbox kept rejecting my ext4 partition. This related question: Dropbox: ext4 isn't ext4 offered some suggestions but at some point the Dropbox icon disappeared from my system tray.

Dropbox is running -- I created a new text file and it syncs to another Dropbox instance promptly, but without the tray icon I can't open the preferences and if I cant open the preferences I can't designate a new sync location.

There are a lot of questions that seem related, but no so far none of the solutions work.

As suggested in several answers, I ran dropbox stop && DBUS_SESSION_BUS_ADDRESS="" dropbox start which doesn't seem to have made a difference -- still no system tray icon. It did return two warnings which seem relevant:

(dropbox:3946): libappindicator-WARNING **: 19:05:47.t941: Unable to get the session bus: The given address is empty
(dropbox:3946): LIBDBUSMENU-GLIB-WARNING **: 19:05:47.941: Unable to get session bus: The given address is empty

What can I do with this libappindicator-WARNING? Or is there a way to pull up the Dropbox preferences window without the system tray icon? I'm on 18.04, running Gnome. dropbox status reports that Dropbox is up to date.

3
  • What is your desktop environment (GNOME, KDE, MATE, Xfce)?
    – N0rbert
    Oct 28 '18 at 7:55
  • added it. Gnome.
    – Amanda
    Oct 28 '18 at 16:01
  • 1
    Two wild guesses, 1) look for a config file to edit manually in a text editor (look in ~/config/...) or failing that try 2) test for additional command options by typing dropbox in terminal and double-tapping the Tab key to see if anything is suggested. Unlikely but this has saved me before when trying to discover random CLI options. Oct 28 '18 at 19:02
2

I wound up running Software Updater and restarting, which restored the system tray icon.

I'm slightly annoyed that that's what worked but I guess the moral of the story is: check for software updates before you tear your hair out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.